[SOLVED] Cura 3.2.1 Naruszenie ochrony pamięci

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie [SOLVED] Cura 3.2.1 Naruszenie ochrony pamięci

Ten wątek zawiera 5 odpowiedzi, ma 3 uczestników, ostatnio zmodyfikowany przez azja azja 9 miesięcy temu.

Oglądasz 6 posty - 1 do 6 (z 6 ogółem)
  • Autor
    Posty
  • #7014

    -adam
    Forumowicz

    Po aktualizacji nie uruchamia się skąd pobrać starszą wersję ,jak na złość wyczyściłem pobrane paczki /var/cache/pacman/pkg.

    #7015
    majo
    majo
    Moderator

    Starsze pakiety znajdziesz w ALA: https://wiki.archlinux.org/index.php/Arch_Linux_Archive
    W większości powinny działać w Manjaro.
    Kurę znajdziesz tu: https://archive.archlinux.org/packages/c/cura/

    Instalacja wcześniejszego pakietu (lub innego, po zmianie adresu Url, wg Twojego uznania)
    sudo pacman -U https://archive.archlinux.org/packages/c/cura/cura-3.1.0-1-x86_64.pkg.tar.xz

    Manjaro [stable] LTS, Xfce - tego używam

    #7016

    -adam
    Forumowicz

    Starsza wersja nie pomogła ale znalazłem to https://github.com/thopiekar/Cura-packaging/issues/27 i obniżyłem python-pyqt5-5.9.2 do tej wersji, kura gdacze .

    #7021
    azja
    azja
    Moderator

    … kura może i gdacze, ale jak będziesz instalował pakiety z wolnej ręki – z pominięciem pacman’a – i dowolnie podmieniał pliki w systemie za jego plecami, to Ci kaczka zdechnie.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7031

    -adam
    Forumowicz

    Dlaczego z pominięciem ? pacman o wszystkim wie (z menu zainstaluj lokalne pakiety) nawet chce go aktualizować do 5.10.1 .
    Kaczka ma się dobrze nawet dzielnie zniosła przeniesienie na inną grzęde ( dysk zewnętrzny usb na stacjonarny )
    gruby na siłę na gpt

    #7034
    azja
    azja
    Moderator

    … chce aktualizować, bo zszedłeś z wersją poniżej aktualnej. Jeżeli nie wrzucisz na listę wyjątków, to będzie chciał za każdym razem. Jeżeli wrzucisz, to nie będziesz miał aktualnego pakietu python-pyqt5. Moim mainstream’em jest gtk, ale używam również aplikacji pisanych pod qtpython-pyqt5 jest wymagany przez 9 innych pakietów (u mnie) i gdybym obniżył wersję, to kwestią czasu byłyby problemy z którymś z nich, bo zacząłby wymagać wersji Y, a otrzymywałby tylko X. Musisz liczyć się z tym, że za tydzień, miesiąc, kilka … kaczce przestanie podobać się, to że preferujesz kurę jej kosztem i wyjdzie na podwórko z głośnym kwakaniem i baseball’em w dziobie.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 6 posty - 1 do 6 (z 6 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.