Gnome – zmiana theme loginu

Jesteś nowy na forum? Przeczytaj ...

Home Fora Środowiska graficzne Inne Gnome – zmiana theme loginu

Ten wątek zawiera 15 odpowiedzi, ma 3 uczestników, ostatnio zmodyfikowany przez azja azja 4 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 16 ogółem)
  • Autor
    Posty
  • #7583
    starcraft2fan
    starcraft2fan
    Forumowicz

    Cześć, jestem nowy z gnome i naszła mnie ochota na zmianę tematu mojego loginu ;)
    Zainstalowałem lightdm i theme do niego, natomiast nie wiem, jak zrobić, by uruchamiał się zamiast defaultowego ekranu logowania.
    Jakaś pomoc? :)

    #7586
    azja
    azja
    Moderator

    … Ustawienia Lightdm GTK+ Greeter / Motyw

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7587

    pavbaranov
    Forumowicz

    Czy w przypadku GNOME jest w ogóle sens zmieniać GDM (który niesie jeszcze kilka innych rzeczy dla GNOME niż samo DM), w dodatku na niezbyt rozwijany LightDM, który nadto nie oferuje (chyba nadal) wsparcia dla sesji GNOME w Wayland? Rezygnować z użyteczności GDM tylko dlatego, że coś co widzisz przez kilka sekund (i bez czego można się obejść w ogóle) nie podoba Ci się? Nadto prawdopodobieństwo, że przy jakiejś aktualizacji GNOME/Gtk+ 3 lub sterownika grafiki do nowszej wersji LightDM się rozleci i nie będziesz miał możliwości wejścia (lub będzie utrudniona) do sesji jest wyższe niż w przypadku używania DM rozwijanego wraz z samym GNOME (choć pamiętać należy, że zmiana tematu w GNOME już nie jeden raz doprowadziła do zwisu to środowisko z powodu niekompatybilności z jakimś tematem, który nie pochodzi od GNOME).
    Cóż… nie mój system :)

    Niemniej jednak, choć GDM (jak całe GNOME3) łatwy w konfigurowaniu nie jest, to:
    1. O małym wyborze tematów do niego raczej mówić nie można (część niestety to będą jednak tematy dla GDM <3).
    2. Są możliwości zmiany np. samego tła.
    3. Jest program do konfiguracji GDM (jest w AUR).
    4. Jakaś w ogóle konfiguracja też jest możliwa.

    Niemniej jednak – wracając do Twojego pytania: zainstalowałeś LightDM, zainstalowałeś jakiś do niego temat – ok. Tyle, że czego dotyczy Twoje pytanie: faktu, że pomimo zainstalowania LightDM on się nie uruchamia zamiast GDM, czy też, że uruchamia się, ale nie potrafisz go skonfigurować dla wybranej skórki.

    #7588
    azja
    azja
    Moderator

    @pavbaranov -> no fakt, pytanie @starcraft2fan nie jest jednoznaczne.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7590
    starcraft2fan
    starcraft2fan
    Forumowicz

    Pomimo instalacji, nie działa.
    Ogólnie to nie bardzo rozumiem, jak mam zamienić istniejący temat na ten customowy.
    Zrobiłem wszystko wg instrukcji z tego filmiku (theme ten sam)

    #7592

    pavbaranov
    Forumowicz

    Ogólnie to nie bardzo rozumiem, jak mam zamienić istniejący temat na ten customowy.
    Zrobiłem wszystko wg instrukcji z tego filmiku (theme ten sam)

    Sorki, ale jak ktoś robi filmiki, gdzie oczy bolą, bo wszystko skacze, to nie chce mi się tego oglądać, a „zrobiłem wszystko” nic absolutnie nie znaczy.

    1. Jaki DM obecnie masz ustawiony: GDM, czy LightDM (nie zainstalowany, a uruchomiony!!!)? I może od tego zacznijmy. Nt. „zmian” DM masz na wiki: Manjaro, polskiej wiki Manjaro, wiki Archa. Nie chce mi się tego raz jeszcze robić i tu Ci pisać.

    2. Jeśli masz LightDM to sposób jaki podał @azja winien działać 100/100. Jeśli masz GDM w dalszym ciągu – nigdy nie zadziała, bo uruchamiasz GDM a nie LightDM.

    Serio – skoro jesteś „nowy z gnome”, a jak sądzę w ogóle na linuksie, to… dla Twojego dobra – nie zmieniaj niczego, co absolutnie nie jest konieczne, bo za chwilę będzie to ostatnia możliwość otwarcia komputera. Jeśli już musisz, bo inaczej się udusisz (co poniekąd rozumiem), to tematy z Google Material Design są również dla GDM i stosuj to, a nie porzucone wynalazki typu LightDM. To niczemu dobremu nie służy, a ilość powodów do narzekania w Antergosie na to rozwiązanie (tam LightDM jest domyślne), gdzie rozlatuje się on w zasadzie co chwilę jest olbrzymia. Będziesz wiedzieć co masz zrobić, gdy po aktualizacji system się nie uruchomi do graficznego???

    PS: Do moderatora – jakimś cudem podczas edycji opublikował mi się pisany tekst – jeśli można, to usuńcie poprzedni.

    #7601
    azja
    azja
    Moderator

    … publikacja takiej jakości materiałów powinna być ścigana z urzędu i karana wieloletnim zakazem dostępu do smartphone’a. Z tego, co można tam wypatrzeć – i z opisu – wynika, że jest, to lightdm-webkit2-greeter. W takim razie, moja pierwotna porada może być nie na temat.
    … najpierw jednak, jak zauważył @pavbaranov, ustalmy co masz uruchomione. Jeżeli nie wiesz, to choć fotka ekranu logowania, na początek.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7607

    pavbaranov
    Forumowicz

    @azja – Z całym szacunkiem – żadna fotka, bo będziemy się domyślać co to jest, co widzimy :)
    Wynik:

    systemctl status gdm
    systemctl status lightdm
    #7614
    azja
    azja
    Moderator

    … racja :-)

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7630
    starcraft2fan
    starcraft2fan
    Forumowicz

    Proszę o pomoc, a nie porady jak elektrody :D Zwyczajnie mam jakiś cel to szukam instrukcji w internecie co pozmieniać w plikach, powpisywać w terminalu, by uzyskać pożądany efekt. Tak powoli uczę się struktury i zasad działania linucha.
    A jak nie potrafię nic znaleźć to piszę na odpowiednich forach xD To że jestem nowy nie znaczy, że proszę, żebyś mnie zjechał i powiedział jak chujowy jestem. Nie, wskaż błąd i pokaż drogę. Ok, tyle wywodu.
    W opisie filmiku jest link do intalacji tegoż theme i tam postąpiłem wg. instrukcji (tu wklejam punkty)

    1. Download from AUR lightdm-webkit-theme-material-git
    2. Enable the theme in your /etc/lightdm/lightdm-webkit2-greeter.conf
    3. Search for greeter section Set webkit-theme to material

    Wynik z terminala:

    [bartek@bartek-pc ~]$ systemctl status gdm
    ● gdm.service – GNOME Display Manager
    Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
    Active: active (running) since Wed 2018-06-13 01:35:20 CEST; 13h ago
    Main PID: 415 (gdm)
    Tasks: 3 (limit: 4915)
    Memory: 5.8M
    CGroup: /system.slice/gdm.service
    └─415 /usr/bin/gdm

    cze 13 01:35:20 bartek-pc systemd[1]: Starting GNOME Display Manager…
    cze 13 01:35:20 bartek-pc systemd[1]: Started GNOME Display Manager.
    [bartek@bartek-pc ~]$ systemctl status lightdm
    ● lightdm.service – Light Display Manager
    Loaded: loaded (/usr/lib/systemd/system/lightdm.service; disabled; vendor preset: disabled)
    Active: inactive (dead)
    Docs: man:lightdm(1)

    Wniosek: Czyli to o co pytam, jak wyłączyć gdm i uruchomić defaultowo lightdm?
    Wszystko mam wgrane poprawnie, łącznie z theme do lightdm, natomiast nie wiem jak to zmienić, dotąd używałem KDE i była to sprawa kilku kliknięć. :V

    #7633

    pavbaranov
    Forumowicz

    Skoro już nas (mnie pewnie) opierniczyłeś, bo nie chcę Cię poprowadzić za rękę, to bądź też łaskaw i opiernicz siebie. W ostatnim wpisie piszesz:

    Czyli to o co pytam, jak wyłączyć gdm i uruchomić defaultowo lightdm?

    podczas, gdy w pierwszym:

    Zainstalowałem lightdm i theme do niego, natomiast nie wiem, jak zrobić, by uruchamiał się zamiast defaultowego ekranu logowania.

    Widzisz różnicę między „jak wyłączyć gdm i uruchomić defaultowo lightdm”, a „nie wiem jak zrobić, by (lightdm z jakimś tematem) uruchamiał się zamiast defaultowego ekranu”? Nie? Bo ja tak. Z pierwszego postu wynikać mogą dwie sytuacje:
    1. albo masz jedynie wgrany LightDM, wgrany motyw („wszystko zrobiłem dobrze jak na filmiku”), ale nie działa z jakiegoś powodu ów temat (tzn. lightdm włącza się z jego domyślnym wyglądem),
    2. albo wgrałeś jedynie LightDM, ale go nie podniosłeś w miejsce GDM i dalej ów GDM się włącza.
    W zależności od tego – odpowiedzi są różne. Pierwsze w istocie wskazywać może na jakiś problem, który należy rozwiązać. Drugie… cóż znam fora, gdzie „problem” poszedłby od razu do kosza, albowiem skoro zadającemu pytanie nie chce się zajrzeć do dokumentacji systemu operacyjnego, to dlaczego komukolwiek innemu ma się chcieć mu odpowiadać?
    No dobra:
    o uruchamianiu tzw. display manager w systemach opartych o systemd, w tym LightDM

    #7635
    azja
    azja
    Moderator

    @starcraft2fan -> nie myl formy z treścią. Nie bierz formy @pavbaranov do siebie, tylko skup się na treści jaką przekazuje, bo rzeczywiście natura problemu zmieniła się po drodze. Zajrzyj do link’u dotyczącego uruchamiania display manager’ów i sprawdź wszystko dokładnie. Z tego co piszesz wynika, że etap konfiguracji masz za sobą, więc pewnie zostanie ci zastopowanie jednego service’u i uruchomienie drugiego.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7639
    starcraft2fan
    starcraft2fan
    Forumowicz

    Racja.

    Możesz mi jeszcze powiedzieć, dlaczego nie mam tego katalogu i jak go utworzyć?

    [bartek@bartek-pc ~]$ cd /etc/init.d/^C
    bash: cd: /etc/init.d/^C: Nie ma takiego pliku ani katalogu
    [bartek@bartek-pc ~]$ sudo gdm stop
    a
    ^C[bartek@bartek-pc ~]$ sudo service gdm stop
    sudo: service: nie znaleziono polecenia

    Wniosek: Bez tego nie mogę manipulować procesami, czyli nie dojdę do rozwiązania problemu.

    #7642
    azja
    azja
    Moderator

    … skąd potrzeba posiadania tego katalogu? Przeczytałeś text, który linkował @pavbaranov? Mam nieodparte wrażenie, że nie. Zajrzyj tam, przeczytaj i zrealizuj:
    https://wiki.manjaro.org/index.php?title=Install_Display_Managers#LightDM
    Jeżeli będziesz miał jakieś problemy techniczne lub językowe, to pisz, ale najpierw przeczytaj.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7643

    pavbaranov
    Forumowicz

    Możesz mi jeszcze powiedzieć, dlaczego nie mam tego katalogu i jak go utworzyć?

    [bartek@bartek-pc ~]$ cd /etc/init.d/^C
    bash: cd: /etc/init.d/^C: Nie ma takiego pliku ani katalogu
    [bartek@bartek-pc ~]$ sudo gdm stop
    a
    ^C[bartek@bartek-pc ~]$ sudo service gdm stop
    sudo: service: nie znaleziono polecenia

    Wniosek: Bez tego nie mogę manipulować procesami, czyli nie dojdę do rozwiązania problemu.

    Możesz nam powiedzieć, czy jesteś świadomy jakiego sytemu używasz? Gdzie Ty znalazłeś te inity? Arch Linux w październiku 2012 r. przeszedł na systemd, a wkrótce po nim też Manjaro. Tu nie ma „starych” initów.
    Czytasz w ogóle linki, które są Ci podsyłane? Gdzie tam masz: sudo service gdm stop??? Skąd Ci to do głowy przychodzi?

Oglądasz 15 posty - 1 do 15 (z 16 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.