Grafika jak 4-bit (TV Samsung 48")

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Sprzęt i sterowniki Grafika jak 4-bit (TV Samsung 48")

Ten wątek zawiera 5 odpowiedzi, ma 2 uczestników, ostatnio zmodyfikowany przez azja azja 2 tygodni, 4 dni temu.

Oglądasz 6 posty - 1 do 6 (z 6 ogółem)
  • Autor
    Posty
  • #8185
    glon.rzeczny
    glon.rzeczny
    Forumowicz

    Witam,
    jestem nowy na forum, ale postaram się opisać wszystko jak trzeba.

    Mój problem objawia się ty, iż na zewnętrznym TV (Samsung 48″) obraz nie wyświetla się poprawnie. Zamiast normalnego obrazu widać jedynie kontury kształtów złożonych z podstawowych kolorów (obrazek poniżej – w kadrze TV Samsung + laptop, obraz replikowany).

    Co ciekawe w zależności od szczęścia obraz potrafi sam z siebie się naprawić, jest to jednak losowe i czasem trwa to 30sek, czasem 5min a czasem 30min.
    Nie mniej jednak wyciągam na tej podstawię wniosek, że w tle dzieję się coś co to poprawia.
    Pytanie zatem co i czy nie mógłbym tego „zdarzenia” wywoływać sam?

    Zanim postanowiłem napisać to pytanie szukałem oczywiście czy ktoś nie miał podobnego problemu, tj.:
    1. https://superuser.com/questions/1214434/yellow-and-gray-blend-with-white-on-a-remote-monitor-connected-with-a-hdmi-vga-a
    To rozwiązanie mi jednak nie pomogło.
    2. https://forum.manjaro.org/t/dual-monitor-problem-after-recent-manjaro-update-from-20-08-2018/55758
    Ten problem wydaję się być inny, tym bardziej, że ja mam problem jedynie z TV Samsunga 48″

    Laptop: Dell XPS 9370 + adapter HAMA display port type-C => HDMI
    Problem nie występował na innych laptopach podłączanych bezpośrednio prze HDMI z również Manjaro.
    Również używając adaptera z innym laptopem z Windows 10 przez thunderbolta + HAMA problemu nie ma.

    PS. z racji, że zreplikowanie tego jak się samo naprawia jest bardzo losowe postaram się wrzucić filmik jak tylko uda mi się nagrać to zdarzenie telefonem.
    PS. link do nagrania jak problem znika w okolicach 15. sekundy: https://drive.google.com/open?id=1V9FknPxg55LU3PhFUiBJb2STMcq42-sg

    Manjaro XFCE

    #8188
    azja
    azja
    Moderator

    nie mam doświadczenia w tego typu zestawach sprzętowych (mam na myśli, przede wszystkim, HDMI), więc moje uwagi opierają się na doświadczeniach ogólnych i stanowią zestawienie elementów, na które zwróciłbym uwagę, badając problem:
    # Smart – domyślam się, że telewizor jest nowy (sądząc po szerokości ramek), więc należy go podejrzewać o wysoki poziom ‚inteligencji’, która może aktywnie podchodzić do odbieranego sygnału;
    # przegląd konfiguracji TV – być może coś tam będzie, co może dotyczyć problemu i co warto przetestować;
    # gniazdo w telewizorze jest sprawne? Inne urządzenia do niego podłączone, za pomocą tego samego / innego kabla, działają bez problemów?;
    # wykorzystanie innego gniazda (inne HDMI, albo inny standard lub użycie przejściówki, etc.)
    # używane jest tylko HDMI, czy po drodze jest jeszcze jakaś przejściówka?;
    # inne kable? I te same zestawy (pc+kabel) podłączone do innych telewizorów. Chodzi o wykonanie paru testów krzyżowych, aby zorientować się co jest nośnikiem problemu;
    # inny system (np. Windows), na tym samym sprzęcie.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8194
    glon.rzeczny
    glon.rzeczny
    Forumowicz

    Ad. 1

    # Smart – domyślam się, że telewizor jest nowy (sądząc po szerokości ramek), więc należy go podejrzewać o wysoki poziom ‚inteligencji’, która może aktywnie podchodzić do odbieranego sygnału;

    Wyłączyłem, nie pomogło

    Ad. 2

    # przegląd konfiguracji TV – być może coś tam będzie, co może dotyczyć problemu i co warto przetestować;

    Przejrzałem, z naciskiem na wszystko związane z wyświetlaniem obrazu typu: piłka nożna, gry itd.

    Ad. 3

    # gniazdo w telewizorze jest sprawne? Inne urządzenia do niego podłączone, za pomocą tego samego / innego kabla, działają bez problemów?;

    Tak sprawne, działa z innymi Linux-ami zainstalowanymi na laptopach, ale z normalnym HDMI.
    Oraz z Dell Inspiron z Windows 10 prze thunderbolt + ten sam adapter Hama + ten sam kabel

    Ad. 4

    # wykorzystanie innego gniazda (inne HDMI, albo inny standard lub użycie przejściówki, etc.)

    Są dwa, na obu to samo, laptop ma tylko 3 thunderbolt-y, jeden jest display-portem (nie wiem czym się różni poza ikonkom przy nim)
    Inna przejściówka nie wchodzi w grę, nie są zbyt popularne, a i liczą sobie za nie „trochę”

    Ad. 5

    # używane jest tylko HDMI, czy po drodze jest jeszcze jakaś przejściówka?;

    Tak, Hama USB-C Adapter for HDMI

    Ad. 6

    # inne kable? I te same zestawy (pc+kabel) podłączone do innych telewizorów. Chodzi o wykonanie paru testów krzyżowych, aby zorientować się co jest nośnikiem problemu;

    Działa na:
    Yiama, dość stary jeszcze z wejściem DVI: laptop + adapter hama + kabel HDMI<->DVI (kabel inny bo ma DVI)
    LG: laptop + adapter hama + kabel HDMI<->HDMI (kabel ten sam co do TV Samsung)
    Philips: laptop + adapter hama + kabel HDMI<->HDMI (kabel inny bo w robocie)

    Ad. 7

    # inny system (np. Windows), na tym samym sprzęcie.

    Ciężko mi to sprawdzić, musiałbym:
    1. Zrobić kopie zapasową
    2. Zainstalować Windowsa
    3. Sprawdzić i przywrócić kopie
    Jak znajdę czas w weekend to sprawdzę, bo laptop potrzebny do pracy

    Reasumując. Wygląda na to, że:
    1. TV Samsung jest dobry bo inne laptopy z Windowsem lub Linux-em wyświetlają obraz poprawnie
    2. Kabel + adapter jest sprawny, bo działają jak podłącze do monitora
    3. TV Samsung + Kabel + adapter + tunderbolt (display-port) + Dell Inspiron + Windows 10 też działa

    PS.
    Znalazłem również wątek pod linkiem https://bugs.freedesktop.org/show_bug.cgi?id=107157, gdzie opisywany jest ten sam bug (załączone zrzuty ekranu).
    Reported: 2018-07-08 17:48 UTC by Jules Samuel Randolph
    Modified: 2018-07-18 09:19 UTC (History)
    W sumie wychodzi na to, że bug Linux-a.

    Manjaro XFCE

    #8195
    azja
    azja
    Moderator

    sporo różnych kombinacji sprzętowo-programowych. No właśnie, im bardziej skomplikowany i wyrafinowany standard, tym większe prawdopodobieństwo, że w pewnych okolicznościach (przewidywalnych lub nie) mogą pojawić się problemy, ponieważ udział w grze bierze duża liczba czynników. Oprócz wartości nominalnych, z tabliczek znamionowych, trzeba również uwzględnić ‚usprawnienia’ wprowadzane przez większych producentów, czy błędy lub uproszczenia w implementacji. W swojej praktyce osobistej spotkałem się ze sporą ilością przypadków, w których musiałem szukać odpowiednich zestawów, dających pożądany efekt, a jakiś czas temu (dawno temu) przeżyłem frustrujące miesiące spędzone na testach różnych przejściówek USB-COM, ponieważ nie wszystkie działały z drukarkami fiskalnymi.
    widzę tutaj dwa kierunki:
    # próba znalezienia działającego zestawu sprzętowego lub sprzętowo/software’owego (konfiguracja ze strony TV i systemu). Problem może leżeć wszędzie – po stronie TV, systemu, okablowania. Na dodatek, nie musi, to być czyjaś ‚wina’ – ot, po prostu, w pewnych sytuacjach, to co działa w 99%, tutaj nie działa;
    # zajrzenie do log’ów – być może system wykrywa jakieś nieprawidłowości i informuje o tym journal’a.
    ————-
    EDIT-20180829-1434 … można również przyjrzeć się momentowi ‚naprawy’ – być może da radę skojarzyć go w czasie z jakimś innym wydarzeniem; może zauważysz jakąś prawidłowość.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8239
    glon.rzeczny
    glon.rzeczny
    Forumowicz

    Z tą konfiguracją kilku elementów coś jest.
    Żeby nie łazić z kilkoma przejściówkami (bo Dell XPS 9370 ma tylko 3x USB-C) kupiłem sobie dongla HUB Adapter Green Cell USB-C 7w1 USB HDMI 4K SD PD .

    Jak podłączyłem TV to laptop z Manjaro + gnizdo w donglu HDMI + kabel + TV zadziałało elegancko.

    Teraz męczę się dlaczego mi recievera Logitecha nie wykrywa jak podłącze do USB w donglu.
    Ale to jeszcze sprawdze czy tak samo jest z pendrive-ami, kartą SD itd.

    EDIT: podłączyłem do DisplayPortu (z prawej strony), działa HDMI i USB.

    PS. zanim podłączyłem do TV z-flash-owałem biosa, tym programikiem fwupd – ArchWiki (poprzednia przejściówka Hama USB-C Adapter for HDMI nadal nie działa prawidłowo).

    pozdrawiam i dzięki za pomoc

    Manjaro XFCE

    #8248
    azja
    azja
    Moderator

    ale kombajn z tego HUB Adapter Green Cell. Cena zniechęca, ale jeżeli ma się USB-C, to funkcjonalność urządzenia jest nie do pogardzenia. No i wygląda na ładne i przyzwoicie wykonane. Poza tym, jak widać, im więcej różnych portów, tym więcej możliwości różnych zestawień i większe prawdopodobieństwo, że któreś zadziała.
    dla porządku – fwupd jest w repozytorium Manjaro:
    community/fwupd

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 6 posty - 1 do 6 (z 6 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.