[SOLVED] Ile wersji starych kerneli pozostaje w Manjaro

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Podstawy [SOLVED] Ile wersji starych kerneli pozostaje w Manjaro

Ten wątek zawiera 4 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez azja azja 2 miesięcy, 3 tygodni temu.

Oglądasz 5 posty - 1 do 5 (z 5 ogółem)
  • Autor
    Posty
  • #8313

    alaskan_malamute
    Forumowicz

    Czy Manjaro sam usuwa wcześniejsze kernele? Czy są usuwane podczas samego update? Przy update kernela w Manjaro nie zauważyłem żeby pojawiły się w konsoli jakieś informacje o usuwaniu starszej wersji.

    W Ubuntu starsze wersje kerneli były cały czas obecne i
    sudo apt-get autoremove
    https://help.ubuntu.com/community/RemoveOldKernels
    usuwało starsze wersje. Nie pamiętam czy wszystkie, bo w grub były widoczne starsze wersje. W razie potrzeby można było w grub wybrać wcześniejszy kernel.

    Manjaro używam około 1,5 miesiąca, więc to nie pierwszy update kernela jaki był w tym czasie, a w systemie widać tylko ostatni:

    mhwd-kernel -li
    Currently running: 4.14.71-1-MANJARO (linux414)
    The following kernels are installed in your system:
       * linux414
    
    #8314
    Tomek
    Tomek
    Forumowicz

    Listę wszystkich wspieranych kerneli powinieneś mieć w ustawieniach systemowych (a przynajmniej ja mam w Manjaro KDE). Tam też masz opcję usunięcia lub zainstalowania kernela. W twoim przypadku kernel 4.14 ma wydłużony okres wsparcia, więc możesz pracować na nim nawet kilka lat.
    Jakiś czas temu miałem sytuację, że skończyło się wsparcie dla kernela. Wtedy przy aktualizacji poinformowało mnie, że mam nieaktualny kernel i że muszę go usunąć w ustawieniach systemowych. Osobiście polecam mieć zainstalowane przynajmniej 2 kernele, aktualny LTS i najnowszy stabilny.

    #8316
    Robert75
    Robert75
    Forumowicz

    Czy Manjaro sam usuwa wcześniejsze kernele? Czy są usuwane podczas samego update? Przy update kernela w Manjaro nie zauważyłem żeby pojawiły się w konsoli jakieś informacje o usuwaniu starszej wersji.

    Manjaro nie usuwa wcześniejszych wersji kerneli, tylko je aktualizuje, chyba że zostały oznaczone jako EOL, w tym wypadku nie będzie aktualizowany. Po starszych wersjach jądrach pozostaje tylko ślad w /var/log.
    I oczywiście w pamięci podręcznej, którą można wyczyścić poleceniem:
    pacman -Scc

    Anarchy Xfce - 64Bit Linux User #621110
    https://anarchy-linux.org/

    #8317
    napcok
    napcok
    Administrator

    Porządkując temat…
    1. Manjaro przy aktualizacji usuwa stare kernele automatycznie – w ramach jednej linii kernela
    W przeciwieństwie do Ubuntu, który pozostawia stare kompilacje jądra i sam widziałem serwery gdzie było po kilkanaście kerneli
    2. W Manjaro możesz mieć zainstalowanych kilka „linii” kernela np. 4.14, 4.18, 4.9 i wybierać podczas rozruchu, którą wersję jądra chcesz uruchomić.
    Szczerze polecam wszystkim tą opcję np. mieć najnowszą stabilną wersję kernela + ostatnią wersję z długim wsparciem LTS.

    Dodaję obrazek poglądowy :)
    Zainstalowane kernele z serii:
    4.18 – ostatni stabilny
    4.14 – ostatni z wydłużonym okresem wsparcia.

    Załączniki:
    #8319
    azja
    azja
    Moderator

    @alaskan_malamute -> masz wersję 4.14 kernel’a, bo Manjaro – w trakcie instalacji systemu – instaluje najnowszą wersję LTS (Długi Okres Wsparcia). Jeżeli doinstalujesz (xfce4-settings-manager / Manjaro Settings Manager / Kernels) wersję 4.18, czyli najnowszą wersję stabilną, będziesz miał zalecany zestaw – zalecany przez kolegów wyżej, jak i przeze mnie. Najnowszy stabilny kernel będzie wtedy domyślnym i ma służyć do codziennej pracy (stabilność + nowe funkcjonalności), a najnowszy LTS leży w rezerwie – na wypadek wypadku (dwa tygodnie temu lekko posypało mi się w systemie, ale uruchomiłem na rezerwowym kernel’u i pracowałem dalej, analizę problemu zostawiając na później – nie jest, to lek na całe zło, ale czasem przydaje się). Oczywiście, niezależnie od ilości kernel’i, musisz zadbać o to, aby instalować nowe ich wersje (nowe linie, np. 4.19, która pojawi się w najbliższych miesiącach jako stabilna) i odinstalowywać stare, szczególnie jeżeli staną się EOL (Koniec Wsparcia, czyli porzucenie, brak poprawek bezpieczeństwa choćby).

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 5 posty - 1 do 5 (z 5 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.