Karta pamięci problem

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Inne Karta pamięci problem

Ten wątek zawiera 29 odpowiedzi, ma 6 uczestników, ostatnio zmodyfikowany przez  lysyy 5 miesięcy, 1 tydzień temu.

Oglądasz 15 posty - 16 do 30 (z 30 ogółem)
  • Autor
    Posty
  • #5474

    pavbaranov
    Forumowicz

    Masz jakąś zwariowaną własnościową nvidię? Jeśli nie – doinstaluj na próbę linux-zen od Archa (archlinux.org i znajdziesz), potem musisz wydać:
    update-grub
    Po restarcie wybierz w GRUB linux-zen i sprawdź czy dalej nie możesz zamontować tej karty.

    #5487

    lysyy
    Forumowicz

    Po drugie, masz nieaktualny kernel, powinien być w wersji 4.9.39-1.

    Gdy chcciałem zaktualizować kernel to pokazuje mi że 4.9.39-1 działa i jest zainstalowany i jak teraz wkładam kartę to jej wogole nie widzi , a tak mi sie przypomina ze kiedyś ten komunikat mi się wyswietlał ale można było przejżec zawartość karty pamięci , po jakiejś aktualizacji coś się zepsuło

    #5490

    pavbaranov
    Forumowicz

    @azja – Mieszasz chłopakowi w głowie. Co ma wersja kernela do wiatraka? Widzisz gdzieś tutaj nagle obsługę vFAT, nadto wprowadzoną w poprawkowej wersji kernela bez regresji w tym zakresie?
    Także PKGBUILD tego kernela oraz config – z tego co widzę – nie uległ w Manjaro zmianie i vfat jest zbudowany jako moduł kernela (FUSE zresztą też). Moduły znajdują się w paczce linuxXY i po rozpakowaniu winny być w lokalizacji /usr/lib/modules/4.9.38-1-MANJARO/kernel/fs/fat/ i nazywać się vfat.ko.gz. Dlzczego jednak tego nie masz – trudno powiedzieć.

    @lysyy: Jedyne co przychodzi mi do głowy to:
    – przeinstalować kernel (można sprawdzić, czy wszystko zainstalował przez:
    pacman -Qk linux49`
    ale znając życie niczego nie pokaże.
    – zainstalować – choćby na próbę inny kernel i spróbować otworzyć na nim nieszczęsną kartę,
    – zdiagnozować poprzez journalctl i dmesg co się dzieje po włożeniu karty oraz próbie jej otwarcia przez Thunar.
    Jeśli się na to ostatnie zdecydujesz:
    1. otwierasz konsolę (to się w XFCE bodaj terminal nazywa), a w zasadzie dwie i wpisujesz:
    w pierwszejć
    journal-f`
    Wkładasz kartę, w drugiej konsoli wywołujesz thunar, próbujesz otworzyć kartę. Wynik tego co w obu konsolach powinien coś nam powiedzieć zatem jeśli sam nie wiesz o co chodzi – umieść tu lub na jakimś pastebinie.
    Możesz też od razu otworzyć trzecią konsolę, w której wydajesz polecenie:
    dmesg
    przed włożeniem karty – też interesujące co pokaże choć i tak winno być w dzienniku.

    Możesz spróbować również pomysł Robert75 z jakimś innym menedżerem plików (sugerowałbym konsolowy mc). Z dotychczasowych informacji wynika jednak, że nie ma co podnieść.

    I jeszcze @azja:

    @pavbaranov -> dlatego napisałem ‚choćby pobieżną’. Poziom wiedzy użytkowników forum (które jest dla wszystkich, również tych, którzy wczoraj po raz pierwszy zobaczyli komputer na oczy) jest skrajnie różny. Porada nie będzie w pełni skuteczna, jeżeli nie będzie do niego dostosowana.

    Wielce dziękuję za pouczenie :D

    EDIT:
    Jeszcze jedno – „kiedyś działało (przynajmniej częściowo) – teraz nie”. Przez przypadek nie pogrzebałeś za bardzo w katalogu głównym?

    EDIT2:
    I jeszcze jedno pokaż nam wynik:
    locate /usr/bin/mount

    #5491
    azja
    azja
    Forumowicz

    … podałeś, że masz:
    Linux gelo-pc 4.9.38-1-MANJARO #1 SMP PREEMPT Sat Jul 15 12:18:15 UTC 2017 i686 GNU/Linux
    Domyślam się, że nie pisałeś ‚z ręki’, tylko skopiowałeś. Jeżeli soft (uname zapewne) podał Ci wersję 4.9.38-1, a teraz mówisz, że ‚działa i jest zainstalowany’ 4.9.39-1, to coś tu nie gra. Sprawdź raz jeszcze, tym samym poleceniem, którego użyłeś TUTAJ.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5492

    lysyy
    Forumowicz

    ~ … podałeś, że masz:
    Linux gelo-pc 4.9.38-1-MANJARO #1 SMP PREEMPT Sat Jul 15 12:18:15 UTC 2017 i686 GNU/Linux
    Domyślam się, że nie pisałeś ‚z ręki’, tylko skopiowałeś. Jeżeli soft (uname zapewne) podał Ci wersję 4.9.38-1, a teraz mówisz, że ‚działa i jest zainstalowany’ 4.9.39-1, to coś tu nie gra. Sprawdź raz jeszcze, tym samym poleceniem, którego użyłeś TUTAJ. ~

    skopiowałem i wkleiłem

    [gelo@gelo-pc ~]$ uname -a
    Linux gelo-pc 4.9.38-1-MANJARO #1 SMP PREEMPT Sat Jul 15 12:18:15 UTC 2017 i686 GNU/Linux

    a tu zrzut

    #5494

    pavbaranov
    Forumowicz

    @lysyy – Jeszcze prośba – staraj się stosować tagi, bowiem przestaje być czytelne co jest cytatem, co Twoją wypowiedzią.

    #5497

    lysyy
    Forumowicz

    Panowie nie wiem co się dzieje , ale coś namieszałem i działa
    Wyłączyłem laptopa i poszedłem po beer , wróciłem ze sklepu włączyłem i lapek widzi kartę, wyswietla się komunikat „że nie można zainstalować woluminu ” ale klikam na zamknij, wtedy otwiera się karta pamieci i można zobaczyc(kopiować, kasować) pliki na karcie

    Dziękuję wszystkim za porady

    #5498

    Deleted
    Member

    To może podziel się z nami, jakie to piwo, co okazało się takie pomocne?

    #5499
    azja
    azja
    Forumowicz

    @pavbaranov -> to ma wersja kernel’a do wiatraka, że raz jest jedna, po czym jest inna – uważasz, że to normalna sytuacja , że wszystko gra? Dwa różne źródła, w tym samym systemie, podają różne wersje kernel’a – nie znam się na tym, bo co mogę wiedzieć, ale zastanawia mnie taka sytuacja i nawet przy niskim poziomie mojej bystrości, zauważam, że nie powinna ona mieć miejsca.
    Co do pouczania, to każdy ocenia innych podług siebie. Ja nie pouczam innych, ale jeżeli ktoś chce, to chętnie dzielę się swoim punktem widzenia. Sądziłem, że zostanę zrugany za pisanie banałów nt. fundamentów przekazywania wiedzy, a nie że zostanie mi ostentacyjnie okazane lekceważenie – nie dbam o to, ale lekko mnie, to zaskoczyło. Cenię Cię za Twoją wiedzę, ale to nie jest powód, abym się z Tobą we wszystkim zgadzał – to jakiś absurd.

    @lysyy ->z dwóch miejsc w systemie otrzymujesz niespójne informacje nt. wersji. Do tego brak modułów, których obecności należy się spodziewać. Nie działo się coś nienormalnego w systemie, nie instalowałeś pozastandardowych rzeczy lub w ‚niekoszerny’ sposób, nie dokonywałeś jakichś magicznych operacji w celu rozwiązania innego problemu? Moim zdaniem, sytuacja jest zastanawiająca i trzeba ją wyjaśnić, a przynajmniej wyprostować. Karta może i czyta się, ale jeżeli masz skopany system, to pojawia się pytanie – kiedy i co następne?. No, ale, to Ty decydujesz.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5501

    lysyy
    Forumowicz

    @lysyy ->z dwóch miejsc w systemie otrzymujesz niespójne informacje nt. wersji. Do tego brak modułów, których obecności należy się spodziewać. Nie działo się coś nienormalnego w systemie, nie instalowałeś pozastandardowych rzeczy lub w ‚niekoszerny’ sposób, nie dokonywałeś jakichś magicznych operacji w celu rozwiązania innego problemu? Moim zdaniem, sytuacja jest zastanawiająca i trzeba ją wyjaśnić, a przynajmniej wyprostować. Karta może i czyta się, ale jeżeli masz skopany system, to pojawia się pytanie – kiedy i co następne?. No, ale, to Ty decydujesz.

    Wiadomo że chcial bym żeby działał bezproblemowo ale jestem za cienki w Linux żeby wszystko ogarnąć , mam jeszcze mały problem z glosnością bo czasami sam się podgłaśnia i ścisza i przez bluetooth nie moge przesłać plików , ale to juz inna historia

    #5505

    pavbaranov
    Forumowicz

    @lysyy – Hmmm… Jakby to powiedzieć:
    – albo w systemie masz coś skopanego,
    – albo locate niezupełnie zindeksowało system,
    – albo sam już nie wiem co.
    Dwie ostatnie rzeczy nie są problemem, drugą naprawisz wydając:
    sudo updatedb
    i odczekując chwilę na prompta.
    Pierwsza – może być poważniejsza. Ściągnąłem właśnie na dysk kernel linux49. Po jego rozpakowaniu ma on moduł vfat.ko.gz w spodziewanej lokalizacji: /usr/lib/modules/4.9.39-1-MANJARO/kernel/fs/fat/. Sprawdź raz jeszcze (np. przez ls, jakimś menedżerem plików) czy masz, czy też nie masz taki plik. Jeśli nie masz, to sugerowałbym ponowną instalację kernela, albowiem ta, która jest nie jest w takim przypadku pełna.

    @azja – Tylko, że gdy radziłeś aktualizację kernela nic nie wiedziałeś o przedstawianiu się jego w systemie raz jako 4.9.38 raz jako 4.9.39. Nadto – gdybyś przeanalizował informacje, które podałem – doszedłbyś do takiego samego wniosku: w zakresie, który istotny jest z punktu widzenia obsługi vfat w systemie nie nastąpiła żadna zmiana tak w samych źródłach, jak i w budowaniu z nich kernela w Manjaro. Mniejsza o to i o to jak się ów kernel zgłasza. Nic to nie zmieni.
    Aha, broń boże nie wymagam, by ktoś się ze mną zgadzał. Zwłaszcza w 100%. Chyba nigdzie tego nie zawarłem.

    #5513
    azja
    azja
    Forumowicz

    @pavbaranov -> nie radziłem aktualizacji kernel’a. Przeczytałem raz jeszcze swój text i niczego takiego tam nie znalazłem. Jedynie zwróciłem uwagę na to, że jest nieaktualny (co w systemie rolling release może mieć znaczenie, jak wiesz). Różni nas, przede wszystkim, podejście do rozwiązywania problemów. Ty wydajesz polecenie i oczekujesz jego wykonania, a ja dochodzę do rozwiązania poprzez analizę różnych możliwości, wymianę poglądów i swobodną dyskusję. Przynajmniej, w większości przypadków, bo zdarza się, że w sytuacji jednoznacznej, nie pozostawiającej wątpliwości, co do natury problemu, stosuję metodę ‚milcz i rób co ci każę’ – ale tylko wtedy, gdy nie mam żadnych wątpliwości (np. gdy problem jest rutynowy, a jego rozwiązanie wielokrotnie sprawdziło się). Jeżeli nie zgadzam się z kimś, to polemizuję, przy użyciu argumentów merytorycznych, na tyle na ile pozwala mi na to moja wiedza, kultura osobista i samoopanowanie.
    … proponuję (prank!) wyznaczać opiekunów/moderatorów poszczególnych postów/problemów. Wtedy inni nie będą się wcinać, ze swoimi ignoranckimi uwagami.

    @lysyy -> nie zachęcam i nie proponuję Ci takiego rozwiązania, bo jest ono na końcu listy narzędzi, jakie wykorzystuję, ale – rozważ instalację systemu od nowa. Czasem, aby się czegoś nauczyć, trzeba to zniszczyć. System, to nie piramidy egipskie, więc możesz bez negatywnych konsekwencji zainstalować go od nowa, szczególnie jeżeli jest świeży i nie masz w nim rozbudowanych mechanizmów, których odtworzenie byłoby czasochłonne. W swoich prywatnych Windows’ach zachowałem ciągłość od końca lat 90. do dzisiaj, od Windows 2000 Beta do Windows 10 – ale to dzięki temu, że wcześniej zniszczyłem odpowiednią ilość instalacji, a i potem zmuszony byłem polec, raz po raz. Podobnie z Manjaro – zwiększam swoje doświadczenie, wyciągając wnioski ze swoich porażek, a nie ciesząc się sukcesami. Zanim osiągnąłem stabilną instalację, którą opłaca mi się ratować, przy użyciu dużej ilości czasu, uśmierciłem wcześniej kilka innych, które budowały coraz większą stabilność przychodzących po nich. Jeżeli chcesz być świadomym użytkownikiem, musisz słuchać innych, ale podejmować własne decyzje – czasem błędne, shit happens.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5518

    pavbaranov
    Forumowicz

    nie proponuję Ci takiego rozwiązania, bo jest ono na końcu listy narzędzi, jakie wykorzystuję, ale – rozważ instalację systemu od nowa.

    No coś w tym systemie – jak się wydaje – nie do końca gra. Z sugestią @azja wstrzymałbym się jednak przez chwilę, by nie robić czegoś co najmniej dwa razy. Wpierw wyjaśniłbym kwestię „zgubienia się” części kernela. Jeśli jakieś pliki „gubią się” w systemie, wyparowują z dysku, to w zasadzie mam dwie możliwe odpowiedzi: zostały usunięte lub przyczyna leży w wadliwym działaniu dysku. Pierwsze – proste, nawet bez postawienia systemu na nowo można zainstalować w systemie wszystkie paczki, jakie się w nim znajdują. Zaletą takiego rozwiązania jest, że nie traci się konfiguracji systemowej, a ewentualne nowe, inne konfiguracje pojawić się powinny w plikach *.pacnew lub *.bak. Drugie wymaga sprawdzenia dysku, ale wpierw wydałbym polecenie:
    pacman -Qk > weryfikacja.txt
    Dokona weryfikacji paczek pod względem, czy zawierają one wszystkie pliki jakie z nimi winny zostać dostarczone. Przekierowanie do pliku tesktowego, bowiem łatwiej go przeglądnąć.

    OT:
    @azja – Ja oczekuję wyłącznie odpowiedzi na zadawane pytania aby móc zdiagnozować ewentualną przyczynę wadliwego działania. Dopiero wówczas jest co analizować. Staram się również nie wprowadzać zamętu do głowy zwłaszcza osobom, które dopiero ten system poznają. Wprowadzanie pobocznych kwestii, które raczej nie mają związku z oczekiwanym rozwiązaniem za takie odbieram. Tak też np. odbieram stwierdzenie: Po drugie, masz nieaktualny kernel, powinien być w wersji 4.9.39-1. Oczywiście nie mówi to o konieczności, nie doradza wprost aktualizacji kernela, ale… to rolling release i jeśli nawet nie sugeruje wprost to zawsze wprowadzi autosugestię: mam coś nie tak z kernelem, powinienem mieć aktualny-nowszy itd. itp., albowiem tu leży pies pogrzebany. Otóż w przypadku sprawy z tego wątku, aczkolwiek w istocie z kernelem jest coś nie tak, to nie ma to nic wspólnego z tym, czy wersja zainstalowana w systemie to 4.9.38, czy 4.9.39 czy jakakolwiek inna. Wszystkie kernele Manjaro mają w tym zakresie (vfat) taki sam config. Wszystkie źródła kerneli leżące u ich podstaw ów vfat obsługują. Sugerowanie czegokolwiek, co nie jest związane z rozwikłaniem problemu – moim zdaniem – wprowadza właśnie takie mącenie komuś w głowie i sprowadza dyskusję na tory, na których nie powinna się ona znaleźć. To tak gwoli wytłumaczenia mojego punktu widzenia i z mojej strony to koniec już tego OT.

    #5526
    azja
    azja
    Forumowicz

    … zgadzam się z tym, co @pavbaranov napisał na temat braku plików, z jednym uzupełnieniem – wadliwe działanie dysku ma/może mieć dualny charakter:
    # software’owy, czyli problem z systemem plików. Przyczyny mogą być różne, nie będę teraz tego rozwijał (temat sam w sobie), natomiast skutki można zlikwidować stosowną komendą;
    # hardware’owy, czyli wadliwe działanie dysku na poziomie jego mechaniki (przy dyskach talerzowych) i/lub elektroniki. Wtedy: S.M.A.R.T. i skanowanie powierzchni.
    Mogą również występować kombinacje obu czynników (np. problematyczny sprzęt może generować problemy na poziomie systemu plików).

    *) to tylko uzupełnienie, nie alternatywne rozwiązanie, proszę nie generować wpisów z protestami.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5586

    lysyy
    Forumowicz

    Pokazało mi ze są aktualizacje systemu wiec zainstalowałem i juz wersję pokazuje wszędzie ok , juz sam się nie podglaśnia, tylko przez Bluetooth telefon widzi jako „źródło audio „po podłączeniu telefonu kablem widzi go ale nie mozna przejżeć plików i jak włożę pendrive to pokazuje komunikat że „nie można zamontować woluminu ” a poza tym jest juz wszystko ok
    Co z tym zrobic ?

Oglądasz 15 posty - 16 do 30 (z 30 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.