Lightdm failed – problem po aktualizacji systemu.

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie Lightdm failed – problem po aktualizacji systemu.

Ten wątek zawiera 27 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez  pavbaranov 2 tygodni, 5 dni temu.

Oglądasz 13 posty - 16 do 28 (z 28 ogółem)
  • Autor
    Posty
  • #7784

    pavbaranov
    Forumowicz

    Przypuszczam, że ściągnąłeś Manjaro Deepin (na to wskazuje wpis w lightdm.conf; to, że się obecnie zgłasza jako GNOME, to jest kwestia GDM). Jeśli tak (kurcze, czy o każdą rzecz się trzeba dopytywać i wszystkiego domyślać), to rozwiązanie jest w linku pod zgłoszonym błędem i winno Ci się udać przywrócić lightdm do życia. Wówczas możesz spokojnie odinstalować GDM.

    #7790
    azja
    azja
    Moderator

    … można wiedzieć dlaczego:

    /etc/lightdm/lightdm.conf
    ---------------------
    greeter-session = Session to load for greeter

    jest odkomentowane (bez # na początku wiersza)?

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7791

    pavbaranov
    Forumowicz

    Ave – do zakomentowania i powrotu do oryginału. W ogóle edytowałeś to?

    #7803

    enszur
    Forumowicz

    Jest odkomentowane, ponieważ w poradnikach przy instalacji deepinitp. było aby odkomentować więc to uczyniłem. Ale swoją drogą, nie mogę zainstalować repozytoriów z deepin w zakładce kategorie – przycisk zastosuj nie jest aktywny. Po ściągnięciu przez konsolę deepin i instalacji i reboocie nadal to samo wszystko. Nic się nie zmienia. Przy odpalaniu wyskakuje mi error w związku z nouvea.

    #7804

    pavbaranov
    Forumowicz

    Geeezaaa… setki problemów, a miał być jeden.
    1. Odkomentowanie tego, na co wskazał @azja jest idiotyczne. Popatrz:

    /etc/lightdm/lightdm.conf
    ---------------------
    greeter-session = Session to load for greeter

    I co teraz ma wykonać lightdm? „Session to load for greeter”??? Tego nie zna. Niestety nie jest to jeszcze SI i nie wie co po „=” ma być. Zakomentuj! Odkomentowane może być wyłącznie wówczas, gdy pod „Session to load for greeter” wstawisz jakiś parametr, który chcesz. Nie wiesz (a nie wiesz) jaki – nie rób nic.
    2. Jakie repozytoria deepin? Jedyne mi znane są z paczkami *.deb. Grupa deepin, to inna sprawa i zupełnie inna kwestia, która na 100% nie jest związana z lightdm.
    3. Nie miałeś ściągać deepin, a zastosować się do porad na bugsach Archa, które Ci wskazałem wcześniej nawet pogrubionym tekstem. Nic więcej!. Powinno się lightdm uruchomić. Przynajmniej na skutek tego błędu, bowiem jak widać więcej ich u Ciebie.
    4. O błędzie z nouveau nic nie wiemy i to również na inny wątek.

    Po pierwsze – jeśli chcesz używać lightdm (GDM przy deepinie nie ma żadnego sensu! – tu możesz zainstalować SDDM, MDM, ale nie GDM) – wykonaj to co powyżej.
    Po drugie – jeśli wykonasz, a będą jakieś błędy, to będą one inne, niezwiązane z lightdm – zgłoś w odrębnym wątku.
    Po trzecie – jakieś „repozytoria Deepin” – trzeci wątek.

    #7814
    azja
    azja
    Moderator

    @enszur -> dla jasności, bo widzę, że nie widzisz problemu:
    # wiersz

    /etc/lightdm/lightdm.conf
    ---------------------
    # greeter-session = Session to load for greeter

    jest opisem. Jest częścią większego opisu, podręcznym help’em mającym Ci wyjaśnić znaczenie poszczególnych parametrów. Powinien być zakomentowany, aby oprogramowanie nie próbowało go przetwarzać – jest dla Ciebie, nie dla niego.
    # wiersz z właściwym parametrem jest niżej, w sekcji Seat:*

    /etc/lightdm/lightdm.conf
    ---------------------
    [Seat:*]
    #greeter-session=example-gtk-gnome

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7817

    pavbaranov
    Forumowicz

    @azja – Z całym szacunkiem, ale lekko pomieszałeś (dla laika; nie Tobie to tłumaczę).
    Masz absolutną rację, że odkomentowanie owego:
    # greeter-session = Session to load for greeter
    w miejscu i w sposób, w jaki to zostało dokonane nie ma żadnego sensu, a LightDM (greeter) nie będzie w stanie przetworzyć „Session to load for greeter”.
    Masz też rację – sterowanie obecnego LightDM odbywa się w sekcji [Seat:*] i to tu dokonujemy zmian. Niemniej jednak takie coś:

    [Seat:*]
    #greeter-session=example-gtk-gnome

    niczego nie wnosi, albowiem jest zakomentowane. Tzn. niezależnie czy będzie zakomentowane, czy nie – i tak podniesie Gnome (będzie chciało podnieść gnome). Aby dokonać zmian należy:
    1. odkomentować wpis
    2. w miejscu example-gtk-gnome umieścić to co potrzebne (tu coś z Deepin, ale nie wiem jak się to akurat w tym przypadku nazywa, a nie chce mi się szukać).
    Dopiero wówczas sesja deepin zostanie podniesiona prawidłowo.

    #7819
    azja
    azja
    Moderator

    … dałem wpisy z oryginalnego lightdm.conf (a dokładniej z lightdm.conf.pacnew), tak aby nie mieszać moją zmodyfikowaną konfiguracją. Doprecyzowuję:

    aby coś zakomentować (wiersz stanie się wtedy wyłącznie informacją text’ową dla człowieka, a maszyna nie będzie go przetwarzać, zignoruje go) należy przed tym, co chcemy wyłączyć z przetwarzania dodać # (hash/kratka)
    #lock-memory=true
    albo
    lock-memory=true #ten paramaetr słuzy do pam-param-pam
    bo # nie musi być od początku wiersza, może komentować tylko jego fragment (od # do końca wiersza).

    po nazwie parametru i znaku równości (sposoby zapisu mogą być różne i zależą od konkretnego programu) musi być coś sensownego, akceptowalnego przez dane oprogramowanie. W tym przypadku, może być:
    lock-memory=true
    ale
    lock-memory=prawda
    nie, ponieważ nie ma większego sensu lokalizować plików konfiguracyjnych i program rozumie true i false, ale prawda i fałsz, albo ene-due-rabe już nie.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7820

    pavbaranov
    Forumowicz

    Pamiętajmy jednak, że w przypadku LightDM (i nie tylko jego) – niemal wszystkie wiersze zakomentowane są jednocześnie domyślnie przetwarzane. Stąd w wielu przypadkach nie ma znaczenia, czy mamy ‚#cośtam = coś’czy mamy cośtam = coś, bo to na to samo wychodzi. dopiero dokonanie zmiany na cośtam = inne_coś daje spodziewany efekt. Choć nie zawsze tak to działa i często jest jak mówi @azja (szczególnie w oprogramowaniu z dawnych, dobrych czasów). Zresztą wszystko zależy od tego, czy oprócz jakichś *.conf np. w /etc/ nie ma jakichś szkieletów, do których program dobiera się, gdy już żadnych plików konfiguracyjnych nie ma. W przypadku dystrybucji, które każą wszystko/wiele robić samemu (Gentoo, Arch) – takich szkieletów prawie nie ma, ale w przypadku dystrybucji „user-friendly” takich sporo. I mam tu wieczne pytanie – dlaczego to q… nie jest porządnie opisane, że w porównaniu do rozwiązania upstreamowego wprowadziliśmy X do plików konfiguracyjnych, które zamieściliśmy w Y. Kurcze ani filozofii skończyć nie trzeba, ani też tych kilka słów nie zbawi.

    Podsumowując wątek @enszur:
    1. Zrobić porządek w pliku *.conf
    2. Zrobić to co pod zgłoszeniem błędu w Archu.
    3. Ew. wyedytować linię, na którą wskazuje @azja (ale w Sink) i dopisać sesję deepin.
    LightDM musi zadziałać.

    #7821

    enszur
    Forumowicz

    Zainstalowałem sddm, zakomentowałem to. Odpalił się system na nowo tylko wyskakuje ekran logowania i ani myszka nie działa i klawiatura. Kursor miga w miejscu hasła i nic nie mogę zrobić.
    I wyskakuje mi w biosie Pointer to TMDS table invalid

    #7822

    pavbaranov
    Forumowicz

    Co zakomentowałeś? W SDDM nie istnieje taki wpis jak w LightDM. Całe /etc/sddm.conf w moim przypadku (komentarze po #):

    cat /etc/sddm.conf
    [Autologin] # generalnie ma znaczenie wyłącznie jeśli się używa automatycznego logowania do systemu
    Relogin=false # tu: "nie" - nie będzie w razie błędu próbował ponownie logować mnie do domyślnej sesji
    Session=plasma.desktop # to owa domyślna sesja dla autologowania
    User=pb # domyślny użytkownik
    
    [General]
    HaltCommand=
    RebootCommand=
    
    [Theme] # nie ma większego znaczenia - ustawienia wyglądu
    Current=breeze 
    CursorTheme=breeze_cursors
    
    [Users] # znaczenie ma, ale nie jest istotne teraz o tym rozmawiać
    MaximumUid=65000
    MinimumUid=1000

    Jeśli chodzi o błąd, który masz – na 99% to nie kwestia związana z DM. Teoretycznie po zabiciu SDDM powinieneś mieć możliwość uruchomienia Deepin przez bodaj startdde. Coś się u Ciebie posypało również z innymi rzeczami, jak tylko LightDM. W sumie, to temat na inny wątek. Proponuję przywrócić Manjaro Deepin do w miarę oryginalnego poziomu, czyli zrobić to co w moim poprzednim wpisie (oczywiście też uruchomić LightDM). Jeśli będzie występował błąd z urządzeniami wejściowymi, to załóż nowy, a ten pozostawmy na lepsze czasy, gdy już owe urządzenia wejściowe działać będą.

    #7823
    aquila
    aquila
    Moderator

    Właściwie ten wątek powinien znaleźć się w koszu. Twoje lakoniczne wypowiedzi oraz próba instalacji innych DM, dezorientują nas jak i potencjalnych przyszłych użytkowników. Dodatkowo dwóch panów ciągle dyskutujących, nie koniecznie na temat, rozbuchują, ostatnimi czasy, wątki do niebotycznych rozmiarów. Czemu to ma służyć? Nie wiem, lecz na pewno nie pomoże to osobom, które szukając odpowiedzi, będą musiały przebrnąć przez gąszcz niepotrzebnych informacji.
    Ja mam takie do Ciebie pytania i sugestie:
    1. Z jakim środowiskiem graficznym zainstalowałeś Manjaro? (może masz iso na kompie lub na penie).
    2. Czy doinstalowywałeś całe jakieś środowisko?
    3. Skoro nie daje nam pewności wynik inxi -S ,jakie posiadasz środowisko graficzne, to może doinstaluj, jeśli nie masz, screenfetch i podaj jego wynik.
    4. Podaj:

    pacman -Qs lightdm

    5. Jeśli jednak mamy dalej rozwiązywać problem dotyczący tematu, to odinstaluj wszystkie inne DM i skup się na lightdm.

    #7827

    pavbaranov
    Forumowicz

    @enszur – Wykonaj tę listę (masz komentarze jak uznałem za potrzebne). Aha, zakładam, że Twoje środowisko to Deepin w Manjaro Deepin (zobacz, czy się nie mylę). Teraz już lista:
    1. Gdy pojawi Ci się SDDM: ctrl+alt+F2 podajesz swój login, enter, hasło (nie będzie widoczne podczas wpisywania), enter.
    2. sudo systemctl stop sddm
    3. sudo pacman -Rns gdm
    4. sudo pacman -Syu deepin deepin-extra networkmanager
    5. sudo nano /etc/lightdm/lightdm.conf w sekcji [Seat:*] dopisz:
    greeter-session=lightdm-deepin-greeter
    zamknij edytor zapisując zmiany.
    6. sudo ln -s /usr/share/backgrounds/deepin/desktop.jpg /usr/share/backgrounds/default_background.jpg
    7. sudo ln -s /usr/share/backgrounds/deepin/desktop.jpg /usr/share/backgrounds/background_desktop.jpg
    8. sudo systemctl disable sddm
    9. sudo systemctl enable lightdm
    10. sync && reboot
    W ten sposób powinieneś wyrzucić z systemu GDM wraz ze wszystkim co przyniósł (3); dokonać aktualizacji oraz ponownej instalacji całego Deepin DE (4), instalacji, konfiguracji i uruchomienia lightdm, deaktywacji sddm oraz zrestartowania systemu. Sprawdź, czy to działa. Na razie jeszcze nie usuwaj SDDM (może się przydać).
    Jeśli będą jakieś błędy – napisz jakie.
    Jeśli dalej będzie to Pointer to TMDS table invalid, to ten błąd jest związany ze sterownikiem nouveau i w istocie może objawiać się zawieszeniem się systemu na DM. Dobrzy ludzie w necie twierdzą, że zmiana sterownika nouveau na nvidia pomaga w takim przypadku.

Oglądasz 13 posty - 16 do 28 (z 28 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.