[SOLVED] Nie działa PPSSPP

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie [SOLVED] Nie działa PPSSPP

Ten wątek zawiera 13 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez Robert75 Robert75 9 miesięcy, 2 tygodni temu.

Oglądasz 14 posty - 1 do 14 (z 14 ogółem)
  • Autor
    Posty
  • #2480
    Robert75
    Robert75
    Forumowicz

    Po zainstalowaniu emulatora PPSSPP nie chcę działać, po prostu po uruchomieniu gry, gra się uruchamia i po 10 sekundach emulator się wyłącza. Nie wiem może to zmiana kernela z 4.4 na 4.9 ma na to wpływ. Chciałbym dodać że po instalacji emulatora zrobiłem restart kompa.

    Manjaro Xfce Linux User #621110

    #2482

    michaldybczak
    Forumowicz

    Jak jest problem z jakimś programem to uruchom go z terminala, żeby zobaczyć w czym problem. Dopiero wtedy wiadomo czego szukać.

    #2483
    Robert75
    Robert75
    Forumowicz

    A jakim poleceniem należy to sprawdzić?

    Manjaro Xfce Linux User #621110

    #2488

    michaldybczak
    Forumowicz

    Po prostu uruchamiasz terminal i wpisujesz nazwę programu (małymi literami) i enter. Czasem trzeba sprawdzić nazwę programu, tu można zajrzeć do plików desktop czy menu startowego jakim poleceniem uruchamia (możliwe na KDE, prawo klik na ikonę startu i wybierz edycja programów).

    Sprawdź sobie jak to działa. Wpisz „firefox” i kliknij enter. Firefox się uruchomi i zobaczysz wszystkie wiadomości co się dzieje, w tym różne ostrzeżenia (tak zawsze z programami gtk jest) oraz błędy jeśli występują. Jeśli program działa poprawnie, można je zignorować, jeśli coś jest nie tak, to warto się im przyjrzeć.

    #2489
    Robert75
    Robert75
    Forumowicz

    Mi się zdaję że tu nie jest winny program PPSSPP tylko gry. Ponieważ w repo ROSY jest wersja PPSSPP 1.2 natomiast w Manjaro jest PPSSPP 1.3 i może być tak że ta nowsza wersja PPSSPP nie obsługuje tych gier. A oto wynik.

    [robson@amd ~]$ ppsspp
    OpenGL 2.0 or higher.
    W: file_util.cpp:178: IsDirectory: stat failed on /usr/bin/assets/lang/en_US.ini
    W: file_util.cpp:178: IsDirectory: stat failed on /usr/bin/lang/en_US.ini
    52:34:274 Core/Config.cpp:957 I[LOAD]: Loading controller config: /home/robson/.config/ppsspp/PSP/SYSTEM/controls.ini
    Pixels: 960 x 544
    Virtual pixels: 960 x 544
    I: gpu_features.cpp:126: GPU Vendor : NVIDIA Corporation ; renderer: GeForce 7600 GT/PCIe/SSE2 version str: 2.1.2 NVIDIA 304.134 ; GLSL version str: 1.20 NVIDIA via Cg compiler
    E: PCMain.cpp:659: Output audio samples: 1024 (requested: 2048)
    I: prioritizedworkqueue.cpp:33: Flushed 0 un-executed tasks
    52:50:412 Core/Config.cpp:1039 I[LOAD]: Config saved: /home/robson/.config/ppsspp/PSP/SYSTEM/ppsspp.ini
    52:50:413 Core/Config.cpp:1052 I[LOAD]: Controller config saved: /home/robson/.config/ppsspp/PSP/SYSTEM/controls.ini
    I: NativeApp.cpp:996: NativeShutdown called

    Manjaro Xfce Linux User #621110

    #2490

    pavbaranov
    Forumowicz

    Zadam takie pytanie z innej beczki: czy masz już prawidłowo skonfigurowany sterownik NVidii? Jeśli nie, to zbyt wcześnie się bawić w ppsspp.

    #2491
    Robert75
    Robert75
    Forumowicz

    Widocznie nie mam.Ponieważ są problemy z autostartem NVidii.Ale np. emulator PCSXR działa bez problemów.

    Manjaro Xfce Linux User #621110

    #2493

    michaldybczak
    Forumowicz

    Hmmm…. Nie jestem ekspertem w tych sprawach i nie znam programów, które próbujesz uruchamiać. Niestety czasem wiadomości nie są zbyt pomocne. Wrzuciłem do googla (zaznacz i wklej, bo forum nie przetrawiło tak długiego adresu):

    https://www.google.pl/search?num=100&client=firefox-b-ab&q=file_util.cpp%3A+IsDirectory%3A+stat+failed+on+%2Fusr%2Fbin%2Fassets%2Flang%2Fen_US.ini&oq=file_util.cpp%3A+IsDirectory%3A+stat+failed+on+%2Fusr%2Fbin%2Fassets%2Flang%2Fen_US.ini&gs_l=serp.3…13368.16543.0.17689.2.2.0.0.0.0.220.402.0j1j1.2.0….0…1c.1.64.serp..0.0.0.jiQeRBVGdCc

    Chyba to jednak nie powinno blokować uruchamiania się programu. Podejrzanie wygląda „I: prioritizedworkqueue.cpp:33: Flushed 0 un-executed tasks”. Tyle google zwraca na ten temat(zaznacz i wklej, bo forum nie przetrawiło tak długiego adresu):

    https://www.google.pl/search?num=100&client=firefox-b-ab&q=I%3A+prioritizedworkqueue.cpp%3A33%3A+Flushed+0+un-executed+tasks&oq=I%3A+prioritizedworkqueue.cpp%3A33%3A+Flushed+0+un-executed+tasks&gs_l=serp.3…102768.102768.0.103267.1.1.0.0.0.0.184.184.0j1.1.0….0…1c.1.64.serp..0.0.0.1uPZ1sJd6tw

    Musisz jakoś to przejrzeć, rozgraniczyć, może zmodyfikować wyszukiwanie. Ja nie jestem w temacie i nie znam programu. Jak sprawa jest niszowa to niestety nie zawsze da się coś sensownego znaleźć.

    #2495

    pavbaranov
    Forumowicz

    Jeśli nie masz prawidłowo skonfigurowanej karty graficznej, to wykorzystujący OpenGL emulator też będzie wadliwie działać. Najpierw karta, a potem emulator. Wszak jedno i drugie wykorzystuje ten sam sterownik. Jeśli po prawidłowej konfiguracji karty nadal będą błędy w emulatorze, to należy się wówczas temu przyglądnąć. Tak, rozwiązujemy dwa problemy na raz, z czego jeden może być zależy od drugiego.

    #5808
    Robert75
    Robert75
    Forumowicz

    Okazało się wersja 1.4.2-2 jest wadliwa, zainstalowałem starszą wersje 1.2.2-1 i wszystko działa idealnie.
    Starszą wersje można pobrać stąd:
    https://archive.archlinux.org/packages/p/ppsspp/
    I najważniejsze, po zainstalowaniu starszej wersji PPSSPP system będzie chciał ją zaktualizować do najnowszej wadliwej wersji. W takim wypadku otwieramy pamac, preferencje i ignorowanie aktualizacji dla: wybieramy + i zaznaczamy ppsspp.

    Manjaro Xfce Linux User #621110

    #5809
    azja
    azja
    Moderator

    … nie zapominaj, że system zakłada, że jest aktualny w całości. Jeżeli robisz wyjątek, to musisz go obsłużyć, pamiętać o nim. Prawdopodobnie zależności masz aktualne, więc innym pakietom nie nabruździsz, ale jeżeli któraś z zależności zaktualizuje się do wersji, z którą ppsspp nie będzie pracował, to problem wróci. Dopóki o tym wiesz, godzisz się na to i pamiętasz o tym – wszystko gra.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5810
    Robert75
    Robert75
    Forumowicz

    @azja Przy instalowaniu starszej wersji PPSSPP nie były instalowane żadne zależności, jedynie sam pakiet PPSSPP. Więc nie widzę żadnego problemu.

    Manjaro Xfce Linux User #621110

    #5819
    azja
    azja
    Moderator

    … nie były instalowane, bo już były zainstalowane. Tak podejrzewałem, dlatego napisałem, że zależności masz prawdopodobnie aktualne. Zależności Manjaro/community/ppsspp: glew, sdl2, hicolor-icon-theme, libzip. Jest jeszcze kilka innych wersji tego pakietu, różniących się zależnościami, ale każda jakieś ma. Problemu nie widzę – w każdym razie, póki co.
    ————-
    EDIT … póki co stary ppsspp chodzi z nowymi, zależnymi pakietami. Teoretycznie, może tak być do końca istnienia naszej galaktyki, ale … praktycznie, raczej krócej.
    ————-

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5827
    Robert75
    Robert75
    Forumowicz

    Temat uważam do zamknięcia.

    Manjaro Xfce Linux User #621110

Oglądasz 14 posty - 1 do 14 (z 14 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.