Nie mogę dodać apletu PulseAudio

Jesteś nowy na forum? Przeczytaj ...

Home Fora Środowiska graficzne XFCE Nie mogę dodać apletu PulseAudio

Ten wątek zawiera 12 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez  pavbaranov 6 miesięcy temu.

Oglądasz 13 posty - 1 do 13 (z 13 ogółem)
  • Autor
    Posty
  • #7656

    piespawlowa
    Forumowicz

    Taki komunikat wyskakuje mi gdy próbuję dodać aplet PulseAudio:

    Aplet „Wtyczka PulseAudio” niespodziewanie zakończył działanie. Uruchomić go ponownie?
    
    W ciągu ostatnich 60 sekund podjęto kilkukrotną próbę ponownego uruchomienia apletu. 
    Ponowić próbę ponownego uruchomienia apletu czy usunąć aplet z panelu?

    Dzieje się tak od początku, kiedy to doinstalowałem XFCE do Maboxa. Sam dźwięk działa. Po kliknięciu „Volume Icon” pojawia się nawet aplet i mogę regulować głośność, jednak przy kolejnej sesji apletu nie ma.
    Czy da się to w jakiś prosty sposób naprawić?

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #7659

    pavbaranov
    Forumowicz

    Możesz podrzucić nazwę paczki z tym apletem?

    #7662

    piespawlowa
    Forumowicz

    To jest najprawdopodobniej xfce4-pulseaudio-plugin 0.4.1-1.1 , ale pewności nie mam.
    Wstyd się przyznać, ale nie wiem za bardzo jak się upewnić.

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #7663
    Robert75
    Robert75
    Forumowicz

    Podstawowe pytanie. Czy masz zaznaczone zapisywanie sesji przed wylogowaniem?

    Anarchy Xfce - 64Bit Linux User #621110
    https://anarchy-linux.org/

    #7664

    piespawlowa
    Forumowicz

    @robert75, tak, mam

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #7665

    pavbaranov
    Forumowicz

    Muszę się dorwać do komputera żony (tam jest też XFCE), ale proponuję dla pewności zrobić tak (zakładam, że – skoro to Manjaro to yaourt masz):

    yaourt -G xfce4-pulseaudio-plugin
    cd xfce4-pulseaudio-plugin
    makepkg -s
    namcap xfce4-pulseaudio-plugin-itd # wyjdzie Ci jak dasz <TAB>
    # jeśli weryfikacja przejdzie prawidłowo:
    makepkg -irc

    I zobacz czy pomogło. W powyższych sytuacjach zwykle robię w ten sposób. Niekiedy to działa – innym razem nie. W Archu nie ma podobnych do Twojego problemu zgłoszeń dla tej paczki.

    #7667
    Robert75
    Robert75
    Forumowicz

    @piespawlowa A czy Ty sam nie namieszałeś coś w systemie? U mnie już leci 9 miesiąc jak mam zainstalowane Manjaro XFCE, i od tego czasu nie wyskakiwał mi nigdy taki komunikat jak Tobie.
    Czyli pakiet jest OK.

    Anarchy Xfce - 64Bit Linux User #621110
    https://anarchy-linux.org/

    #7669

    piespawlowa
    Forumowicz

    Dzięki! Pomogło. Tylko teraz pewnie Pamac będzie cały czas krzyczał, że trzeba zaktualizować.
    @robert75 , jeden allah wie, ale prawdopodobnie ja w tym udziału nie miałem, bo tak było od początku.

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #7670

    pavbaranov
    Forumowicz

    Co pomogło?

    #7671

    piespawlowa
    Forumowicz

    @pavbaranov , Twój przepis pomógł, czyli:

    yaourt -G xfce4-pulseaudio-plugin
    cd xfce4-pulseaudio-plugin
    makepkg -s
    namcap xfce4-pulseaudio-plugin-itd # wyjdzie Ci jak dasz <TAB>
    # jeśli weryfikacja przejdzie prawidłowo:
    makepkg -irc

    Jeszcze raz, dzięki!
    EDIT
    Mam rozumieć, że mam nie aktualizować tego pakietu?

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #7673

    pavbaranov
    Forumowicz

    W takim razie nie tylko pamac, ale przede wszystkim również pacman nie będzie nic krzyczał, że trzeba aktualizować. Zbudowana przez Ciebie paczka jest dokładnie w tej samej wersji, w której jest w repozytorium. Po prostu przebudowałeś paczkę, której dostarczyłeś jakieś „informacje” o czymś, co masz w systemie, o czym jej Twórca mógł nie wiedzieć. Jeśli niczego „zewnętrznego” (czytaj AUR) nie masz w systemie i jednocześnie niczego samo Manjaro nie dostarcza innego w stosunku do oryginalnej paczki (ta pochodzi z Archa), to bóg raczy wiedzieć co się pokiełbasiło. Nie należy się takimi rzeczami przejmować. Przebudować i musi działać.
    Grunt, że pomogło. Generalnie polecam to rozwiązanie niemal w każdym takim przypadku.

    EDIT:
    Na IRC wyszło, że paczka tworzona w ten sposób ma niższy pkgrel od paczki w repozytorium Manjaro (bóg raczy wiedzieć dlaczego). Prawidłowa paczka zostanie stworzona w następujący sposób (zakładam stworzenie w katalogu domowym podkatalogu build, można to pominąć):

    mkdir -p build
    cd build
    mkdir -p xfce4-pulseaudio-plugin
    cd xfce4-pulseaudio-plugin
    wget https://raw.githubusercontent.com/manjaro/packages-extra/master/xfce4-pulseaudio-plugin/PKGBUILD
    wget https://raw.githubusercontent.com/manjaro/packages-extra/master/xfce4-pulseaudio-plugin/use-panel-icons.patch
    makepkg -sirc

    Otrzymana i zainstalowana wersja będzie tożsama z wersją w repozytorium Manjaro.

    #7680
    azja
    azja
    Moderator

    … sprawdź jeszcze, na wszelki wypadek:
    – pamac
    — Grupy
    —— xfce4 / xfce4-goodies – z tych grup powinieneś mieć pakiety z Xfce. Jeżeli w grupach xfce4-gtk3 / xfce4-gtk3-goodies masz jakieś pakiety oznaczone jako zainstalowane, to zalecam odinstalować i zainstalować odpowiedniki gtk2.
    … być może ten problem Ciebie nie dotyczy, ale sprawdź.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7681

    pavbaranov
    Forumowicz

    @azja – Proponowane rozwiązanie zostało już przetestowane. Chodzi i pracuje. Bladego pojęcia nie mam dlaczego yaourt -G pobiera źródła tej paczki w wersji sprzed 2 lub 7 miesięcy (czyli 0.4.1-1, a nie 0.4.1-1.1). W ten sposób po zbudowaniu paczka jest w wersji, o której pacman twierdzi, że nadaje się do aktualizacji. Stąd pomysł z wget. Tym razem zbudowana paczka ma prawidłową wersję (0.4.1-1.1).
    Dlaczego u niektórych paczka z repozytorium pracuje prawidłowo, a u @piespawlowa nie – nie wiem i nie chce mi się dochodzić konkretnej przyczyny (bo ogólną znam), stąd w miarę uniwersalne rozwiązanie tego typu sytuacji.

Oglądasz 13 posty - 1 do 13 (z 13 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.