[SOLVED] Nie mogę zaktualizować Pale Moon

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie [SOLVED] Nie mogę zaktualizować Pale Moon

Ten wątek zawiera 10 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez azja azja 2 miesięcy, 1 tydzień temu.

Oglądasz 11 posty - 1 do 11 (z 11 ogółem)
  • Autor
    Posty
  • #8254

    piespawlowa
    Forumowicz

    Od jakiegoś czasu wyskakuje mi taki oto komunikat przy otwieraniu PM:

    Załączniki:

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8256
    Robert75
    Robert75
    Forumowicz

    Najwidoczniej coś namieszałeś w ustawieniach. Co do aktualizacji to mnie się wydaje że lepiej poczekać aż najnowsza wersja będzie dostępna w repo Manjaro.

    Anarchy Xfce - 64Bit Linux User #621110

    https://anarchy-linux.org/
    #8258
    azja
    azja
    Moderator

    spróbuj (wersja ang.):
    Preferences / Advanced / Update / Never check for updates (not recommended)

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8259

    piespawlowa
    Forumowicz

    Ustawiłem tak, jak na screenie @robert75 ‚a. Nie wiem dlaczego miałem inaczej ustawione, chyba samo się zmieniło. Mam nadzieję, że nie będzie już więcej tego komunikatu. Teraz mam wersję 28.0.0.
    Dzięki :-)

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8260
    azja
    azja
    Moderator

    … w Manjaro jest wersja 28.0.0, a najnowsza stabilna w ogóle, to 28.0.1 – stąd komunikat.
    @piespawlowa -> jak na screen’ie, czyli jak? – bo ja nie widzę żadnego screen’a (nawet wykorzystałem okazję, że uruchomiłem live’a z czystym Firefox’em, bez blokad – również nie widzę żadnego screen’a, za wyjątkiem Twojego).

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8261

    piespawlowa
    Forumowicz

    Nigdy wcześniej nie miałem takich komunikatów, dopiero po ostatniej dużej aktualizacji Manjaro zaczęły się pojawiać z dziwną regularnością, dlatego postanowiłem zapytać na Forum.

    Był screen, ale już go nie ma. Może @robert75 usunął? A pokazywał on, to co Ty proponowałeś, tylko, że po polsku, czyli:
    Preferences / Advanced / Update / Never check for updates (not recommended)

    U Roberta było zaznaczone „Instaluj aktualizacje automatycznie[…]”, a umnie „Nie sprawdzaj aktualizacji[…]”. Teraz mam zaznaczone jak u Roberta.
    Chyba jednak zmienię tak jak było wcześniej, tj. „Nie sprawdzaj aktualizacji[…]”.

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8262
    azja
    azja
    Moderator

    … po ostatniej/przedostatniej aktualizacji, w oknie ‚About Pale Moon’ pojawił się przycisk ‚Check for Updates’ – nie było tego wcześniej w wersji linux’owej. Zapewne to i Twój komunikat, to elementy tej samej modyfikacji programu.
    Preferences / Advanced / Update … wyglądało chyba również inaczej (nie pamiętam, tylko tak mi się wydaje).

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8264
    majo
    majo
    Moderator

    @piespawlowa
    Też mam taki komunikat, którego wcześniej nie było i – jak się domyślam – został wprowadzony wraz z wersją 28.0.0.
    Najwyraźniej musimy poczekać, aż ekipa Manjaro umieści najnowszą wersję PM w repozytorium Manjaro.

    Manjaro [stable] LTS, Xfce - tego używam

    #8265
    azja
    azja
    Moderator

    zawsze tak było i będzie – najpierw produkt pojawia się w magazynie producenta, potem w hurtowniach, następnie w sklepach detalicznych, aby w końcu zawitać w domu user’a. Nasza dystrybucja, to rolling release – tego typu systemy mają świeże wersje programów w swoich repozytoriach. Drobny poślizg jest plusem dodatnim – niewielki, więc nawet dla niecierpliwych powinno być to znośne; a sam fakt, że jest, stanowi bufor, przydatny gdyby okazało się, że aplikacja nie jest jednak tak stabilna, jak się wydawało, albo wchodzi w negatywne interakcje z innymi elementami.
    rozumiem, że problem rozwiązany:
    # komunikat pojawił się wskutek ostatnich zmian w oprogramowaniu;
    # jego histeryczny wydźwięk (Niewystarczające uprawnienia do aktualizacji) wynika z tego, że zwykły user (nawet admin) nie zmodyfikuje plików w /usr (to nie Windows’y) bez autoryzacji;
    # rozwiązaniem problemu jest wyłączenie sprawdzania aktualizacji, która odbywa się (POWINNA!) wyłącznie poprzez pacman’a. Chyba że ktoś chce otrzymywać na ten temat informacje, ale chyba lepszym rozwiązaniem będzie wtedy RSS, newsletter, albo coś w tym rodzaju.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8266
    Robert75
    Robert75
    Forumowicz

    Najwyraźniej musimy poczekać, aż ekipa Manjaro umieści najnowszą wersję PM w repozytorium Manjaro.

    Dziwna sprawa jest z tym PM, ponieważ w repo jest info że to jest najnowsza wersja:

    A z kolei sam PM informuje że jest dostępna aktualizacja.

    Anarchy Xfce - 64Bit Linux User #621110

    https://anarchy-linux.org/
    #8270
    azja
    azja
    Moderator

    @robert75 -> nie widzę na screen’ie (ani u siebie) żadnej informacji o tym, że jest, to najnowsza wersja. Choć z założenia tak jest – to co jest w repozytorium dystrybucji, to najnowsza wersja … dostępna w repozytorium dystrybucji, a nie najnowsza w ogóle (patrz: różnica pomiędzy premierą i prapremierą). Ale, to już temat na inny wątek.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 11 posty - 1 do 11 (z 11 ogółem)

Wątek ‘[SOLVED] Nie mogę zaktualizować Pale Moon’ jest zamknięty.