Problem z kontrolą głośności martwa wtyczka pulseaudio.

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Multimedia Problem z kontrolą głośności martwa wtyczka pulseaudio.

Ten wątek zawiera 23 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez azja azja 1 miesiąc, 2 tygodni temu.

Oglądasz 15 posty - 1 do 15 (z 24 ogółem)
  • Autor
    Posty
  • #8404

    bobek
    Forumowicz

    Witam,
    jestem nowym użytkownikiem manjaro więc proszę o wyrozumiałość.
    Po instalacji nie mam żadnych innych problemów poza brakiem możliwości kontroli głośności
    przyciskami na klawiaturze jak i uruchomienia miksera dźwięku. Dźwięk ogólnie jest ale trochę za cichy.
    załączam zrzuty ekranu z konsoli i zrzut jak chcę wtyczkę sterowania głośnością włączyć.

    Z góry wielkie dzięki za rady.

    #8410
    azja
    azja
    Moderator

    komunikat ‚Proszę czekać…’ jest spowodowany przez ‚Nawiązywanie połączenia z usługą PulseAudio’, z którą nie można nawiązać połączenia, ponieważ usługa nie jest uruchomiona – z jakiegoś powodu ma z tym problemy:
    Active: failed ...
    W ogóle nie startuje przy uruchamianiu systemu:
    Loaded: ... disabled; ...

    na początek, wykonaj:
    sudo systemctl enable pulseaudio
    zrestartuj system, sprawdź dźwięk i stan service’u:
    systemctl status pulseaudio

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8411

    bobek
    Forumowicz

    niestety pierwsze polecenie kończy się errorem:

    [pawel@pawel-pc ~]$ sudo systemctl enable pulseaudio
    Failed to enable unit: Unit file pulseaudio.service does not exist.
    #8412
    aquila
    aquila
    Moderator

    Co wypluwa pulseaudio --start?
    Sprawdź komendy, których możesz użyć by zobaczyć logi pulseaudio -h
    Możesz usunąć katalog .config/pulse zrestartować kompa lub wylogować i zalogować się ponownie.
    Możesz również doinstalować pavucontrol i nim spróbować zwiększyć głośność.

    #8413

    bobek
    Forumowicz

    ad. 1

    [pawel@pawel-pc ~]$ pulseaudio --start
    E: [pulseaudio] main.c: Uruchomienie usługi się nie powiodło.

    ad. 2 .config/pulse już usuwałem niestety nic to nie dało
    ad. 3 pavucontrol mam i nie działa

    #8414

    bobek
    Forumowicz

    odinstalowałem pulse i pavu
    zrobiłem update
    zainstalowałem z powrotem pulse

    [pawel@pawel-pc ~]$ pulseaudio
    E: [pulseaudio] core-util.c: Home directory not accessible: Brak dostępu
    #8415

    bobek
    Forumowicz
    [pawel@pawel-pc ~]$ systemctl --user status pulseaudio
    ● pulseaudio.service - Sound Service
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Fri 2018-10-12 21:44:30 CEST; 3min 34s ago
      Process: 827 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=1/FAILURE)
     Main PID: 827 (code=exited, status=1/FAILURE)
    
    paź 12 21:44:30 pawel-pc systemd[731]: Starting Sound Service...
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Main process exited, code=exited, status=1/FAILURE
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Failed with result 'exit-code'.
    paź 12 21:44:30 pawel-pc systemd[731]: Failed to start Sound Service.
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Service RestartSec=100ms expired, scheduling restart.
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
    paź 12 21:44:30 pawel-pc systemd[731]: Stopped Sound Service.
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Start request repeated too quickly.
    paź 12 21:44:30 pawel-pc systemd[731]: pulseaudio.service: Failed with result 'exit-code'.
    paź 12 21:44:30 pawel-pc systemd[731]: Failed to start Sound Service.
    #8418
    aquila
    aquila
    Moderator

    1. Co na to alsamixer? Może tam jest coś wyciszone?
    2. Czy na Live Manjaro występuje ten problem czy dopiero po instalacji?
    3. Jeśli masz 2 kernele to czy problem występuje na obu?
    4. Podaj inxi -Axx

    PS. Nie pisz posta pod swoim postem tylko edytuj wcześniejszy wpis. Popraw – połącz.

    #8421

    bobek
    Forumowicz

    Ad. 1 Nie miałem zainstalowanego alsamixera i… działa, znaczy zwiększyłem master vol na max bo było na jakieś 60% :)
    Ad. 2 Na Live wszystko działa. po instalacji jest problem i ok teraz sobie pogłośniłem ale przyciski i tak nie działają a na Live tak.
    Ad. 3 Mam dwa kernele? nie rozumiem za bardzo, instalowałem manjaro na czystym nowym dysku jako jedyny system.
    Ad. 4

    [pawel@pawel-pc ~]$ inxi -Axx
    Audio:
      Device-1: Intel 82801I HD Audio driver: snd_hda_intel v: kernel 
      bus ID: 00:1b.0 chip ID: 8086:293e 
      Sound Server: ALSA v: k4.14.74-1-MANJARO 

    Ad. PS – poprawię się.

    #8422
    aquila
    aquila
    Moderator

    To spróbuj tak wydać komendy:

    systemctl --user enable pulseaudio
    systemctl --user start pulseaudio

    Mówiąc o dwóch kernelach, mówię o jądrach systemu. Widzę, że masz 4.14 więc możesz doinstalować nowszy i uruchomić system na nowym.
    Zrobisz to przez Menadźer Ustawień Manjaro -> Jądra lub w konsoli dla jądra 4.18

    sudo mhwd-kernel -i linux418

    Pulseaudio to usługa użytkownika więc możesz jeszcze spróbować utworzyć nowego użytkownika i zobaczyć czy tam wszystko działa.

    #8435

    bobek
    Forumowicz
    [pawel@pawel-pc ~]$ systemctl --user enable pulseaudio
    Created symlink /home/pawel/.config/systemd/user/default.target.wants/pulseaudio.service → /usr/lib/systemd/user/pulseaudio.service.
    Created symlink /home/pawel/.config/systemd/user/sockets.target.wants/pulseaudio.socket → /usr/lib/systemd/user/pulseaudio.socket.
    [pawel@pawel-pc ~]$ systemctl --user start pulseaudio
    Job for pulseaudio.service failed because the control process exited with error code.
    See "systemctl --user status pulseaudio.service" and "journalctl --user -xe" for details.
    [pawel@pawel-pc ~]$ systemctl --user status pulseaudio.service
    ● pulseaudio.service - Sound Service
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor pr>
       Active: failed (Result: exit-code) since Wed 2018-10-17 22:57:58 CEST; 55s a>
      Process: 27184 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, sta>
     Main PID: 27184 (code=exited, status=1/FAILURE)
    
    paź 17 22:57:58 pawel-pc systemd[731]: pulseaudio.service: Service RestartSec=1>
    paź 17 22:57:58 pawel-pc systemd[731]: pulseaudio.service: Scheduled restart jo>
    paź 17 22:57:58 pawel-pc systemd[731]: Stopped Sound Service.
    paź 17 22:57:58 pawel-pc systemd[731]: pulseaudio.service: Start request repeat>
    paź 17 22:57:58 pawel-pc systemd[731]: pulseaudio.service: Failed with result '>
    paź 17 22:57:58 pawel-pc systemd[731]: Failed to start Sound Service.

    Po zainstalowaniu jądra 4.18 i restarcie jest to samo.

    Jednak po utworzeniu nowego użytkownika okazało się, że na nowym koncie regulacja przyciskami funkcyjnymi działa jak należy
    porównując dział sesja i uruchamianie w zasadzie jest to samo oczywiście poza tym, że nie ma usługi pulseaudio na koncie root uruchomionej. Nie rozumiem do końca czemu nie chce się uruchomić.

    #8440

    pavbaranov
    Forumowicz

    Zerknijcie w końcu na to:

    Job for pulseaudio.service failed because the control process exited with error code.
    See „systemctl –user status pulseaudio.service” and „journalctl –user -xe” for details

    Sam system podpowiada co trzeba zrobić by się dowiedzieć, gdzie leży problem.

    #8441

    bobek
    Forumowicz

    pavbaranov przecież podałem komendę którą mi system podpowiedział i widnieje odpowiedź konsoli powyżej.

    #8442

    pavbaranov
    Forumowicz

    pavbaranov przecież podałem komendę którą mi system podpowiedział i widnieje odpowiedź konsoli powyżej.

    Gdzie, bo to o czym pisałem w poprzednim poście – ja nie widzę, ale jestem już stary i ślepy.

    #8443
    azja
    azja
    Moderator

    @bobek -> piszesz o systemctl, a @pavbaranov słusznie wskazuje na journalctl. Najpierw spróbuj uruchomić service:
    systemctl --user start pulseaudio

    a potem wydaj komendę:
    journalctl --user -xe

    i szukaj.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 15 posty - 1 do 15 (z 24 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.