[SOLVED] Błąd aktualizacji-ffmpeg2.8

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie [SOLVED] Błąd aktualizacji-ffmpeg2.8

Ten wątek zawiera 20 odpowiedzi, ma 7 uczestników, ostatnio zmodyfikowany przez aquila aquila 2 miesięcy, 2 tygodni temu.

Oglądasz 15 posty - 1 do 15 (z 21 ogółem)
  • Autor
    Posty
  • #7503

    warsztat-dom
    Forumowicz

    Witam.
    Dziś komunikat o aktualizacji, sporo paczek na ponad 300mb jednak podczas aktualizacji wyskakuje :

    nie udało się rozwiązać zależności:
    instalacja x265(2.8-1) przerwanej zależność ‚li bx265.so=151-64’ wymaganych przez ffmpeg2.8

    czekać czy coś mam skopane ?
    A może jakiś fikimiki z repozytoriami zrobić ?

    Pozdrawiam.

    #7504
    Ulther
    Ulther
    Moderator

    Według głównego forum powinno pomóc

    pacman -R ffmpeg2.8

    Źródło

    #7505
    Robert75
    Robert75
    Forumowicz

    Ja miałem identycznie, dopiero jak usunąłem obcy pakiet ffmpeg2.8 to aktualizacja ruszyła. Ale szkoda wielka że ten pakiet jest zależnością 4Kvideodownloader, bo również ten program musiałem odinstalować. A po zakończonej aktualizacji i reboot-e, chcąc na na nowo zainstalować 4Kvideodownloader-a nie dało rady, ponieważ podczas budowy jest błąd przy pakiecie ffmpeg2.8, a konkretnie nieprawidłowy podpis.

    Manjaro Xfce LTS - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #7507

    pavbaranov
    Forumowicz
    #7511
    Robert75
    Robert75
    Forumowicz

    @pavbaranov Próbowałem zainstalować pakiet ffmpeg2.8 z takim rezultatem.

    [robson@amd ~]$ git clone https://aur.archlinux.org/ffmpeg2.8 && cd ffmpeg2.8 && makepkg -sirc
    Cloning into 'ffmpeg2.8'...
    remote: Counting objects: 4, done.
    remote: Compressing objects: 100% (4/4), done.
    remote: Total 4 (delta 0), reused 4 (delta 0)
    Unpacking objects: 100% (4/4), done.
    ==> Tworzenie pakietu: ffmpeg2.8 2.8.14-1 (pią, 1 cze 2018, 18:30:26)
    ==> Sprawdzanie zależności potrzebnych do uruchomienia...
    ==> Instalowanie brakujących zależności...
    [sudo] hasło użytkownika robson: 
    rozwiązywanie zależności…
    szukanie sprzecznych pakietów...
    
    Pakiety (3) dcadec-0.2.0-1  openjpeg-1.5.2-1  schroedinger-1.0.11-3
    
    Do pobrania:        0,58 MiB
    Do zainstalowania:  2,31 MiB
    
    :: Kontynuować instalację? [T/n] 
    :: Pobieranie pakietów…
     openjpeg-1.5.2-1-x86_64  134,8 KiB   864K/s 00:00 [----------------------] 100%
     schroedinger-1.0.11...   331,6 KiB  4,26M/s 00:00 [----------------------] 100%
     dcadec-0.2.0-1-x86_64    128,6 KiB  5,23M/s 00:00 [----------------------] 100%
    (3/3) sprawdzanie kluczy w bazie                   [----------------------] 100%
    (3/3) sprawdzanie spójności pakietów               [----------------------] 100%
    (3/3) wczytywanie listy plików                     [----------------------] 100%
    (3/3) sprawdzanie konfliktów plików                [----------------------] 100%
    (3/3) sprawdzanie dostępnego miejsca na dysku      [----------------------] 100%
    :: Przetwarzanie zmian pakietu... 
    (1/3) instalowanie openjpeg                        [----------------------] 100%
    Opcjonalne zależności dla openjpeg
        lcms2: j2k_to_image and image_to_j2k programs [zainstalowano]
        libpng: j2k_to_image and image_to_j2k programs [zainstalowano]
    (2/3) instalowanie schroedinger                    [----------------------] 100%
    (3/3) instalowanie dcadec                          [----------------------] 100%
    :: Uruchamianie po-transakcji...
    (1/1) Arming ConditionNeedsUpdate...
    ==> Sprawdzanie zależności potrzebnych do budowy...
    ==> Instalowanie brakujących zależności...
    rozwiązywanie zależności…
    szukanie sprzecznych pakietów...
    
    Pakiety (1) yasm-1.3.0-2
    
    Do pobrania:        0,58 MiB
    Do zainstalowania:  4,35 MiB
    
    :: Kontynuować instalację? [T/n] 
    :: Pobieranie pakietów…
     yasm-1.3.0-2-x86_64      594,7 KiB  1835K/s 00:00 [----------------------] 100%
    (1/1) sprawdzanie kluczy w bazie                   [----------------------] 100%
    (1/1) sprawdzanie spójności pakietów               [----------------------] 100%
    (1/1) wczytywanie listy plików                     [----------------------] 100%
    (1/1) sprawdzanie konfliktów plików                [----------------------] 100%
    (1/1) sprawdzanie dostępnego miejsca na dysku      [----------------------] 100%
    :: Przetwarzanie zmian pakietu... 
    (1/1) instalowanie yasm                            [----------------------] 100%
    :: Uruchamianie po-transakcji...
    (1/1) Arming ConditionNeedsUpdate...
    ==> Pobieranie źródeł...
      -> Pobieranie ffmpeg-2.8.14.tar.xz...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 7052k  100 7052k    0     0  1917k      0  0:00:03  0:00:03 --:--:-- 1916k
      -> Pobieranie ffmpeg-2.8.14.tar.xz.asc...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100   473  100   473    0     0   1008      0 --:--:-- --:--:-- --:--:--  1010
    ==> Sprawdzanie plików source za pomocą sha256sums...
        ffmpeg-2.8.14.tar.xz ... Zgadza się
        ffmpeg-2.8.14.tar.xz.asc ... Pominięto
    ==> Weryfikowanie podpisów plików źródłowych za pomocą gpg...
        ffmpeg-2.8.14.tar.xz ... NIE ZGADZA SIĘ (nieznany klucz publiczny B4322F04D67658D8)
    ==> BŁĄD: Jeden lub więcej podpisów PGP nie może zostać zweryfikowanych!
    ==> Removing installed dependencies...
    sprawdzanie zależności…
    
    Pakiety (1) yasm-1.3.0-2
    
    Odzyskane miejsce na dysku:  4,35 MiB
    
    :: Czy chcesz usunąć te pakiety? [T/n] 
    :: Przetwarzanie zmian pakietu... 
    (1/1) usuwanie yasm                                [----------------------] 100%
    :: Uruchamianie po-transakcji...
    (1/1) Arming ConditionNeedsUpdate...
    [robson@amd ffmpeg2.8]$ 
    

    Manjaro Xfce LTS - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #7512

    JaOrazInni
    Forumowicz

    W instrukcji masz napisane:
    „(pamiętajmy o dodaniu klucza GPG, albo o ominięciu jego sprawdzania przy budowaniu – czego oczywiście nie polecam).”

    #7513
    Robert75
    Robert75
    Forumowicz

    A niby jak mam dodać ten klucz GPG?

    Manjaro Xfce LTS - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #7515

    czapnaper
    Forumowicz

    Jeżeli masz jakiś problem z budowaniem jakiejś paczki z AUR najlepiej zaglądnąć na stronę i sprawdzić komentarze
    gpg --recv-key B4322F04D67658D8.

    Manjaro Gnome/Xfce - CPU - i5-7300HQ - GPU - Intel/NVIDIA GP107M [GeForce GTX 1050 Mobile]

    #7516

    warsztat-dom
    Forumowicz

    Jakoś mi się teraz nie udało a faktycznie , korzystam z 4kvideo…
    Na szczęście działa wersja portable.

    #7517
    Robert75
    Robert75
    Forumowicz

    @czapnaper wielkie dzięki za klucz, oraz dziękuję @pavbaranov.
    ffmpeg2.8 zainstalowany :)

    Manjaro Xfce LTS - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #7518

    pavbaranov
    Forumowicz

    Cóż… mniejsza o to.
    Zobaczcie sobie na PKGBUILD
    Pośród różnych rzeczy, które tam są jest m.in. pole validpgpkeys=. To jest właśnie to pole, które „krzyczy” o podpis PGP. W każdym takim przypadku powinniśmy albo dodać klucz (tak jak to wskazał @czapnaper, albo pominąć walidację przez –skippgpcheck).
    I cóż – mówiąc brutalnie – kolejny przykład, gdzie brak informacji w user-friendly dystrybucji, która korzysta z cudzych repozytoriów. A szkoda bo Manjaro mogłoby być super.

    #7519

    warsztat-dom
    Forumowicz

    Ale Manjaro jak na razi jest całkiem dobre, dzięki Wam doinstalowałem co potrzeba i znowu mam downloadera z paczki.
    Mam teraz zagwozdkę, 4kvideodownloader miętolę :) na paczkę z ubuntowego deba za pomocą debtap. Obecna wersja to 4.4-7 a mi dwa razy po robocie archowa paczka wyskakuje ze starą nazwą 4.4-1, gdzie się coś zapisało ? A może w nowej paczce .deb siedzi stara nazwa ? Za cienki jestem żeby to zrozumieć a że działa nie jest ważne.
    Pozdrawiam.

    #7520

    pavbaranov
    Forumowicz

    1. Ściągasz PKGBUILD.
    2. Edytujesz i zmieniasz pkgver z obecnej na 4.4.7.2307, a pkgrel na 1. Reszta bez zmian.
    3. Wydajesz:
    updpkgsums && makepkg -si
    (możesz również z rc). I chodzi. debtap prawdopooobnie, o ile Cię rozumiem, wadliwie zinterpretował numer wersji. Sprawdź jaki masz zainstalowany w systemie.

    #7521

    warsztat-dom
    Forumowicz

    Wcześniejsza wersja była z 4.4.1 i prawdopodobnie nadał ten sam numer nowej 4.4.7.
    1. Ściągasz PKGBUILD. ??
    Wasz slang nie zawsze dla mnie pojęty.

    Na razie zrobiłem po dziadowsku, rozpakowałem paczkę, zmieniłem nazwę w pkginfo, spakowałem i zainstalowałem ponownie.

    #7522
    Ulther
    Ulther
    Moderator

    Czasem próbę dodania klucza w ten sposób należy powtórzyć kilkakrotnie, problem jest z serverami od kluczy.

Oglądasz 15 posty - 1 do 15 (z 21 ogółem)

Wątek ‘[SOLVED] Błąd aktualizacji-ffmpeg2.8’ jest zamknięty.