Octopi polecenie zakończone błędami

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Podstawy Octopi polecenie zakończone błędami

Ten wątek zawiera 32 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez  pavbaranov 1 rok, 4 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 33 ogółem)
  • Autor
    Posty
  • #3459

    max95100
    Forumowicz

    Witam
    Po ostatniej aktualizacji manjaro wyskoczył mi błąd w Octopi „Polecenie zakończone błędami”. Nie mogłem zresetować komputera w normalny sposób​, więc odłączyłem zasilanie i ponownie włączyłem. Pokazał mi się ekran logowania kde z białym oknem w lewym górnym rogu, i nic więcej. Więc zainstalowalem na nowo cały system. Teraz komputer uruchamia się normalnie, ale cały czas wyskakuje mi ten sam błąd w Octopi. Mimo tego że widzi mi 7 aktualizacji AUR. Jak próbuję zainstalować tę aktualizację w konsoli pokazuje mi że pakiety nie zostały znalezione.

    #3460

    pavbaranov
    Forumowicz

    Teraz komputer uruchamia się normalnie, ale cały czas wyskakuje mi ten sam błąd w Octopi. Mimo tego że widzi mi 7 aktualizacji AUR. Jak próbuję zainstalować tę aktualizację w konsoli pokazuje mi że pakiety nie zostały znalezione.

    Co to znaczy? Jakimi błędami?
    Konsola:
    sudo pacman -Syu
    Jeśli będą błędy – pokaż.
    Konsola:
    yaourt -Sua
    Jeśli będą błędy – pokaż
    O jakie „nieznalezione” pakiety chodzi? Jakie polecenie w konsoli wydawałeś?

    #3461

    max95100
    Forumowicz
    [michal@michal-pc ~]$ sudo pacman -Syu
    [sudo] hasło użytkownika michal: 
    :: Synchronizowanie baz danych z pakietami…
    błąd:  nie udało się zaktualizować core (brak serwerów skonfigurowanych dla repozytorium)
    błąd:  nie udało się zaktualizować extra (brak serwerów skonfigurowanych dla repozytorium)
    błąd:  nie udało się zaktualizować community (brak serwerów skonfigurowanych dla repozytorium)
    błąd:  nie udało się zaktualizować multilib (brak serwerów skonfigurowanych dla repozytorium)
    błąd:  nie udało się zsynchronizować żadnej bazy danych
    błąd:  nie udało się zainicjować transakcji (brak serwerów skonfigurowanych dla repozytorium)
    [michal@michal-pc ~]$
    #3462

    max95100
    Forumowicz
    ==> Budowanie i instalowanie pakietu
    ==> Instalowanie lub budowanie brakujących zależności dla kmozillahelper:
    warning: database file for 'core' does not exist
    warning: database file for 'extra' does not exist
    warning: database file for 'community' does not exist
    warning: database file for 'multilib' does not exist
    ostrzeżenie: database file for 'core' does not exist
    ostrzeżenie: database file for 'extra' does not exist
    ostrzeżenie: database file for 'community' does not exist
    ostrzeżenie: database file for 'multilib' does not exist
    błąd:  pakiet automoc4 nie został znaleziony
    błąd:  pakiet extra-cmake-modules nie został znaleziony
    błąd:  pakiet cmake nie został znaleziony
    warning: database file for 'core' does not exist
    warning: database file for 'extra' does not exist
    warning: database file for 'community' does not exist
    warning: database file for 'multilib' does not exist
    ==> Powtórzyć budowanie kmozillahelper?[t/N]
    ==> ----------------------------------------
    ==>
    #3463
    Robert75
    Robert75
    Forumowicz

    Wygląda na to że Masz żle skonfigurowane mirrory. Aby dodać listę aktywnych mirrorów należy wpisać do terminala: sudo pacman-mirrors --interactive następnie zaznaczyć wszystkie dostępne mirrory i potwierdzić. Najlepiej zrobić restart kompa, a po restarcie odświeżyć repo poleceniem: sudo pacman -Sy I teraz powinno być wszystko ok.

    Anarchy Xfce - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #3469

    pavbaranov
    Forumowicz

    Dodam jeszcze, że przedczymkolwiek:
    sudo pacman-mirrors -g && sudo pacman -Syyu
    Potem zastanów się co chcesz z owego AUR budować. Skoro masz octopi, to prawdopodobnie masz jakieś DE oparte o Qt5. Jeśli tak, to:
    1. Do czego Ci kmozillahelper?
    Kmozillahelper jest to coś, co ma lepiej integrować firefox ze środowiskiem KDE. Którą wersję Manjaro zatem masz? Jeśli jeszcze z KDE4, to należy postawić najnowszą 17 z Plasma 5. Jeśli masz tę wersję, to w community jest paczka firefox-kde oraz kmozillahelper, które są dla Plasma 5. Nie trzeba niczego budować z AUR. Jeśli nie używasz Plasma 5 to w ogóle wersja firefox, która wymaga kmozillahelper nie jest Ci potrzebna.
    2. Zamiast imagewriter rozważ instalację imagewriter-git, bo oparta o Qt5, a nie Qt4.

    Niemniej jednak Twój problem polega na tym, co napisał wyżej Robert75 – wadliwie wygenerowana lista repozytoriów. Najpierw to, potem aktualizacja, potem zabawa z AUR.

    Edit:

    nie wrzucamy tak dużych logów na forum

    Nadto prosiłem wyłącznie o błędy a nie log z budowania, którego doprawdy nie chce się przeglądać by poszukać 5 liniej na krzyż.

    #3487

    max95100
    Forumowicz

    To co mam teraz zainstalowane jest efektem nowej instalacji manjaro. Sam jeszcze nic nie wrzucałem tylko próbowałem aktualizować te 7 pakietów o którym informował mnie Octopi

    P.s.
    Przepraszam za poprzedni log, ale spieszyłem się do pracy, a nie chciało mi zaznaczyć tego co chciałem więc zaznaczyłem wszystko

    #3488

    pavbaranov
    Forumowicz

    Zrobiłeś to co w #3453 i #3469?
    Jakie to Manjaro?
    Staraj się odpowiadać na zadawane Ci pytania, bo dalej nie pójdziemy.

    #3490

    max95100
    Forumowicz

    dzięki pomogło polecenie
    sudo pacman-mirrors -g && sudo pacman -Syyu

    jeśli chodzi o wersje Manjaro to mam najnowszą, wczoraj ściągniętą ze strony manjaro.org. Prawdę mówiąc z AUR-a instaluję tylko to czego nie ma w repozytoriach manjaro czyli;
    -skype
    -spotify
    -chrome

    #3492
    Robert75
    Robert75
    Forumowicz

    A po po co Ci Google Chrome, przecież w repo Manjaro jest Chromium. Te dwie przeglądarki są identyczne, ja na Twoim miejscu bym zainstalował Chromium ponieważ gdy będzie aktualizacja systemu to Chromium zostanie zaktualizowane do najnowszej wersji.

    Anarchy Xfce - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

    #3493

    pavbaranov
    Forumowicz

    wersje Manjaro to mam najnowszą

    Chodziło mi również o to z jakim środowiskiem. Z logów, które wrzuciłeś wynikało bowiem coś przedziwnego:
    – system nie miał skonfigurowanego pacmana do działania w ogóle (to norma – nie wykonałeś podstawowych czynności),
    – miał zainstalowane kmozillahelper, a zatem jak się można domyślić firefox-kde bądź, co mniej prawdopodobne, firefox-kde-opensuse (choć obie paczki są takie same; to tylko inna terminologia),
    – kompilacja kmozillahelper z AUR wywalała się na braku plików *.cmake dostarczanych przez KF5,
    – KF5 musi być w systemie (w tym także te paczki, dostarczające plików *.cmake, których u Ciebie nie były znajdowane) jeśli środowiskiem jest Plasma 5, w części musi być jeśli środowiskiem jest LXQt. W pozostałych środowiskach KF5 jest zbędne jeśli nie używasz jakichś programów jego wymagających (np. kmozillahelper),
    – kmozillahelper i firefox-kde nie mają najmniejszego sensu w środowisku innym od Plasma.
    Innymi słowy – wnioski płynące z Twoich logów były mocno sprzeczne: z jednej strony wygląda to tak, jakbyś miał Manjaro KDE, z drugiej zaś jakbyś miał je z jakimś innym środowiskiem. I stąd pytanie o wersję Manjaro.
    BTW: A propos kmozillahelper – chcesz mieć 2 przeglądarki? Jeśli używasz wyłącznie chrome (pomijając, że przychylam się do zdania Robert75) to nie jest Ci potrzebne kmozillahelper i FF.

    #3497

    max95100
    Forumowicz

    Mam wersję z KDE, da się to jakoś u mnie posprzątać?

    #3500

    pavbaranov
    Forumowicz

    Załóż wątek i napisz co chcesz sprzątać.

    #3502

    max95100
    Forumowicz

    A po po co Ci Google Chrome, przecież w repo Manjaro jest Chromium. Te dwie przeglądarki są identyczne, ja na Twoim miejscu bym zainstalował Chromium ponieważ gdy będzie aktualizacja systemu to Chromium zostanie zaktualizowane do najnowszej wersji.

    Bardziej z przyzwyczajenia, 2 lata temu chromium nie odpalało mi niektórych filmów z youtuba i na forum radzili mi instalacje chroma, w sumie też się aktualizował tyle że w konsoli. Ale tym razem testuje chromium, pewnie przez 2 lata poprawili to i owo ;)

    #3504
    Robert75
    Robert75
    Forumowicz

    Ja używam Chromium od paru ładnych lat (odkąd jestem na Linuksie) i nigdy, ale to nigdy nie miałem z nią problemów. Także podczas oglądania filmów na YouTube. Co do wersji to mamy już 57.0.2987.133 na pewno dawne problemy zostały naprawione.

    Anarchy Xfce - 64Bit Linux User #621110
    PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / Nvidia GeForce 7600 GT / RAM: 8 GB / Dysk: HDD 1 TB

Oglądasz 15 posty - 1 do 15 (z 33 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.