[SOLVED] Problem przy aktualizacji – "icu (63.1-2)

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Oprogramowanie [SOLVED] Problem przy aktualizacji – "icu (63.1-2)

Ten wątek zawiera 11 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez azja azja 2 tygodni, 1 dzień temu.

Oglądasz 12 posty - 1 do 12 (z 12 ogółem)
  • Autor
    Posty
  • #8507

    piespawlowa
    Forumowicz

    Przy próbie aktualizacji Manjaro wyskakuje mi taki błąd:

    błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
    :: instalacja icu (63.1-2) uszkodzi zależności 'icu<63.0' wymagane przez manjaro-settings-manager

    Próbuję takiego zaklęcia:
    sudo pacman -Syu --ignore icu --ignore lib32-icu
    to wyskakuje:

    : Kontynuować instalację? [T/n] t
    :: Pobieranie pakietów…
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z mirror.philpot.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z mirror.ragenetwork.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z manjaro.moson.eu : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z repo.rhindon.net : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z mirror.netcologne.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z mirror.netzspielplatz.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z ftp.rz.tu-bs.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z ftp.tu-chemnitz.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'firefox-63.0.1-0-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
    ostrzeżenie: nie udało się pobrać niektórych plików
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z mirror.philpot.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z mirror.ragenetwork.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z manjaro.moson.eu : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z repo.rhindon.net : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z mirror.netcologne.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z mirror.netzspielplatz.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z ftp.rz.tu-bs.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z ftp.tu-chemnitz.de : The requested URL returned error: 404
    błąd:  nie udało się pobrać pliku 'thunderbird-60.3.0-0-x86_64.pkg.tar.xz' z ftp.halifax.rwth-aachen.de : The requested URL returned error: 404
    ostrzeżenie: nie udało się pobrać niektórych plików
    błąd:  nie udało się dokonać transakcji (niespodziewany błąd)
    Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
    [me@me ~]$ 

    Czy mógłby ktoś pomóc?
    Dziękuję
    PS.
    A może usunąć to całe „icu” w Pamacu i wtedy aktualizacja pójdzie?

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8508
    napcok
    napcok
    Administrator

    Wydaje mi się, że coś nie tak jest u ciebie z listą dostępnych pakietów – spróbuj ją odświeżyć:
    pacman -Syyu
    albo
    pamac update

    #8509

    pavbaranov
    Forumowicz

    1. Poczekaj. Devy Manjaro być może zaspały.
    2. Zmień mirrory – może jednak nie zaspały.
    3. Wykonaj pełną aktualizację systemu!
    4. Jeśli jednak chcesz mieć obecnie tę aktualizację – ściągnij źródła manjaro-settings-manager i przebuduj zmieniając „depends”.
    5. W żadnym przypadku nie wywalaj icu!

    #8511

    piespawlowa
    Forumowicz

    Chyba już wszystko w porządku. Najpierw sudo pacman -Syyu --ignore icu --ignore lib32-icu, później reboot (coś dłuuugo się uruchamiało, więc Shift+Ctrl+F3, a następnie startx), i po załadowaniu (z jakimiś błędami) sudo pacman -Syyu.

    Conky gdzieś mi zniknęło, ale zaraz to sobie poprawię.
    Dzięki!

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8512

    pavbaranov
    Forumowicz

    Żadne „ignore” ICU!!! Od tego zależy (czyt. jest na nowej wersji przebudowywane) od groma paczek. Jeśli chcesz sobie rozwalić system – Twoja sprawa. Masz dokonać pełnej aktualizacji systemu, na aktualnych mirrorach. Bez kombinowania. Jeśli manjaro-settings-manager nie został przebudowany na nowe ICU to masz możliwość wywalenia tego pakietu albo przebudowanie go ze zmianą depends w zakresie ICU. Nie istnieje żadna inna możliwość z wyjątkiem nieaktualizowania systemu. Bez kombinowania!

    #8513

    piespawlowa
    Forumowicz

    Czyli nabroiłem jednak? Przy próbie przeprowadzenia pełnej aktualizacji (sudo pacman -Scc --noconfirm && sudo pacman-mirrors -m rank && sudo pacman -Syu) niby „nie ma niczego do zrobienia”. Obecnie mam icu 63.1-2, zaś zależności manjaro-settings-manager wyglądają tak:

    [me@me ~]$ pacman -Si manjaro-settings-manager
    Repozytorium          : extra
    Nazwa                 : manjaro-settings-manager
    Wersja                : 0.5.5-2
    Opis                  : Manjaro Linux System Settings Tool
    Architektura          : x86_64
    Adres url             : https://gitlab.manjaro.org/applications/manjaro-settings-manager
    Licencje              : GPL
    Grupy                 : Brak
    Dostarcza             : Brak
    Zależy od             : icu<63.2  qt5-base>=5.9.1  hwinfo  kitemmodels  kauth
        .                    kcoreaddons  ckbcomp  xdg-utils
    Opcjonalne zależności : manjaro-settings-manager-notifier: qt-based
                            manjaro-settings-manager-knotifier: knotifications-based
    Komfliktuje z         : kcm-msm
    Zastępuje             : Brak
    Do pobrania           : 2,15 MiB
    Rozmiar po instalacji : 3,81 MiB
    Autor pakietu         : Philip Mueller <philm@manjaro.org>
    Data zbudowania       : wto, 30 paź 2018, 19:24:23
    Potwierdzone przez    : Suma MD5  Suma SHA256  Podpis

    Te Linuksy są dla mnie za trudne.
    Co powinienem zrobić?
    Dziękuję @pavbaranov

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8514
    napcok
    napcok
    Administrator

    Nic nie rób bo wszystko jest w porządku – masz w pełni zaktualizowany system.
    Na przyszłość nie kombinuj „jak koń pod górę” ;)
    W razie wątpliwości przy aktualizacjach najlepiej poczytać oficjalne ogłoszenie na forum Manjaro, po wcześniejszym upewnieniu się, że masz odświeżone listy pakietów – bo u ciebie z tym był problem – nie wiem jakim cudem, ale pacman próbował sciągać jakieś wersje paczek których nie było na mirrorach – prawdopodobnie „wstrzeliłeś się” w mirror nie w pełni zsynchronizowany.
    W takim wypadku warto odczekać chwilę lub dwie i odświeżyć listę pakietów. Kombinowanie z pomijaniem zależności to proszenie się o kłopoty.

    #8516

    piespawlowa
    Forumowicz

    Do aktualizacji zawsze używam zaklęcia: sudo pacman -Scc --noconfirm && sudo pacman-mirrors -m rank && sudo pacman -Syu.
    Przed tym wpisuję:

    sudo pacman -Sc
    sudo pacman -Scc

    oraz
    sudo pacman-optimize && sync.
    To ostatnie przestało jakiś czas temu działać – wyskakuje sudo: pacman-optimize: nie znaleziono polecenia. Co się stało, że przestało działać?

    Co mogę w powyższym usprawnić?

    Niedawno zmieniono motyw wyglądu Elementary Xfce, z którego korzystam. Nie przypadł mi on do gustu i trochę kombinowałem, skutkiem czego było usunięcie Menadżera ustawień (nie wiem jakim cudem), musiałem doinstalowywać. Być może to było przyczyną bałaganu?

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8520
    aquila
    aquila
    Moderator

    Co do pacman-optimize to było na naszym forum. Wątek zaznaczam jako rozwiązany.

    #8521
    azja
    azja
    Moderator

    @piespawlowa -> proponuję inne zaklęcie:

    
    $ sudo pacman-mirrors -f 0 && pamac update --force-refresh --aur
     

    Pierwsza komenda aktualizuje mirror’y, na podstawie konfiguracji z pliku (patrz: niżej). Druga, aktualizuje system (+AUR), odświeżając wcześniej bazę. Sprawdzone, używane od lat – kiedyś pacman, teraz pamac, ale schemat dopracowany i przetestowany.

    /etc/pacman-mirrors.conf
    ---------------------------------
    ## BRANCH PACMAN SHOULD USE (stable, testing, unstable)
    Branch = stable
    
    ## GENERATION METHOD (rank, random)
    Method = rank
    
    ## SPECIFY TO USE ONLY MIRRORS FROM A SPECIFIC COUNTRY
    OnlyCountry = Germany,France
    
    ## DEFINE PROTOCOLS AND PRIORITY SEPARATED
    Protocols = https
    
    ## WHEN SET TO TRUE PREVENTS THE REGENERATION OF THE MIRRORLIST
    NoUpdate = False
    
    ## WHEN SET TO FALSE - ALL CERTIFICATES ARE ACCEPTED
    SSLVerify = True

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #8522

    piespawlowa
    Forumowicz

    Jeszcze raz dzięki wszystkim za pomoc :-) A to Twoje zaklęcie @azja bardzo sprytne, ale mi się dłuuugo aktualizowało…

    Mabox/XFCE. Lenowo Thinkpad T400. 3GB RAM.

    #8529
    azja
    azja
    Moderator

    @piespawlowa -> albo szybko, albo dobrze ;-)
    A tak bardziej serio, to przyczyna zapewne leży w ograniczeniach jakie nakładam na listę mirrorów. Gdy spojrzysz na wpisy w

    
    /etc/pacman-mirrors.conf
     

    jakie stosuję, to zobaczysz, że ograniczam mirrory do konkretnych krajów i tylko po https. To co przejdzie przez ten filtr jest sortowane wg prędkości, ale nie, są to najlepsze transfery, pośród dostępnych. Jeżeli przeszkadza Ci taki stan rzeczy, to wyedytuj/wykomentuj linie:

    
    OnlyCountry = Germany,France
    Protocols = https
     

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 12 posty - 1 do 12 (z 12 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.