[SOLVED] GUFW nie uruchamia się

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Podstawy [SOLVED] GUFW nie uruchamia się

Ten wątek zawiera 31 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez azja azja 9 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 32 ogółem)
  • Autor
    Posty
  • #6808
    majo
    majo
    Moderator

    Przy okazji prób rozwiązania innego problemu (https://manjaro.pl/forum/topic/transfer-danych-po-uruchomieniu-systemu/ ) okazało się, że nie mogę uruchomić firewalla GUFW, ani z poziomu Menu Manjaro, gdzie nic się nie dzieje po wybraniu ikonki firewalla, ani z poziomu konsoli, gdzie wyskakują błędy: https://pastebin.com/EaP3j2Gi

    Bazowy firewall UFW (,do którego GUFW jest nakładką) działa:

    $ sudo ufw status
    Status: active

    Choć patrząc w szczegóły:

    $ sudo ufw status verbose
    Status: active
    Logging: on (low)
    Default: deny (incoming), allow (outgoing), disabled (routed)
    New profiles: skip

    widzę, że działa on inaczej, niż sugerują to w poradniku Ubuntu, gdzie pokazany wynik działania poniższej komendy, powinien być następujący:

    $ sudo ufw status verbose
    [sudo] password for youruser:
    Status: active
    Logging: on (low)
    Default: deny (incoming), allow (outgoing)
    New profiles: skip 

    Zatem u mnie jest dodatkowy parametr: disabled (routed), który być może jest przyczyną zaistniałego problemu?
    ( Tu znalazłem informację, że to jest normalne ustawienie dla routera. Ale.. może się mylą? )

    Czy ten mój wynik komendy sudo ufw status verbose, Waszym zdaniem, jest poprawny?
    I jak ewentualnie powinienem spróbować rozwiązać ten problem z GUFW/UFW?

    Manjaro [stable] LTS, Xfce - tego używam

    #6810
    azja
    azja
    Moderator

    … u mnie wynik komendy jest taki sam i uważam, że jest prawidłowy – Twój komp nie prowadzi żadnej działalności, którą mógłbyś nazwać route’owaniem, prawda? gufw startuje mi bez problemów i nie wyrzuca żadnych komunikatów błędu. Moim zdaniem, problem leży w gufw, nie w ufw. Ciekawe, co autor ma na myśli, pisząc: Unable to init server. O jaki server chodzi – ufw.service? Spróbuj, przed i po próbie uruchomienia gufw, komendy:
    sudo systemctl status ufw
    i sprawdź różnice (zapewne pojawią się nowe komunikaty na dole).
    … a jeżeli pisząc ‚server’ nie ma na myśli ufw, to w takim razie co?

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #6811
    majo
    majo
    Moderator

    Mój komputer nie zajmuje się żadnym routingiem. Natomiast urządzenie do łączenia się z siecią, formalnie nazywa się routerem i posiada teoretycznie możliwość routowania połączenia internetowego 36 użytkownikom (poprzez kabel i wifi). Praktycznie jest tylko 1 użytkownik.

    ufw.service – wydaje mi się – działa poprawnie.
    Stan przed gufw:

    $ sudo systemctl status ufw
    ● ufw.service - CLI Netfilter Manager
       Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: 
       Active: active (exited) since Tue 2018-02-13 08:11:10 CET; 4h 14min ago
      Process: 220 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCC
     Main PID: 220 (code=exited, status=0/SUCCESS)
    
    lut 13 08:11:08 pcn systemd[1]: Starting CLI Netfilter Manager...
    lut 13 08:11:10 pcn systemd[1]: Started CLI Netfilter Manager.
    ...skipping...
    ● ufw.service - CLI Netfilter Manager
       Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: 
       Active: active (exited) since Tue 2018-02-13 08:11:10 CET; 4h 14min ago
      Process: 220 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCC
     Main PID: 220 (code=exited, status=0/SUCCESS)
    
    lut 13 08:11:08 pcn systemd[1]: Starting CLI Netfilter Manager...
    lut 13 08:11:10 pcn systemd[1]: Started CLI Netfilter Manager.
    ~

    Stan po gufw:

    $ sudo systemctl status ufw
    ● ufw.service - CLI Netfilter Manager
       Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: 
       Active: active (exited) since Tue 2018-02-13 08:11:10 CET; 4h 16min ago
      Process: 220 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCC
     Main PID: 220 (code=exited, status=0/SUCCESS)
    
    lut 13 08:11:08 pcn systemd[1]: Starting CLI Netfilter Manager...
    lut 13 08:11:10 pcn systemd[1]: Started CLI Netfilter Manager.
    ...skipping...
    ● ufw.service - CLI Netfilter Manager
       Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: 
       Active: active (exited) since Tue 2018-02-13 08:11:10 CET; 4h 16min ago
      Process: 220 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCC
     Main PID: 220 (code=exited, status=0/SUCCESS)
    
    lut 13 08:11:08 pcn systemd[1]: Starting CLI Netfilter Manager...
    lut 13 08:11:10 pcn systemd[1]: Started CLI Netfilter Manager.
    ~

    Porównałem oba wyniki (porównując pliki tekstowe) i nie ma żadnych różnic poza czasem: „Xmin ago”.

    Edit:
    Porównałem także wcześniejsze i aktualne wyniki działania komendy gufw i są identyczne.

    Manjaro [stable] LTS, Xfce - tego używam

    #6814
    azja
    azja
    Moderator

    … wygląda na to, że z ufw.service nie dzieje się, w trakcie uruchamiania gufw, nic godnego raportowania. Spojrzał bym do logów systemowych, aby sprawdzić czy nie pojawi się tam coś jeszcze, oprócz komunikatów błędów podczas uruchamiania programu. Jeżeli wykonasz komendę:
    journalctl -f
    to będziesz miał log ‚na żywo’ i będziesz mógł obserwować wpisy w trakcie wykonywania gufw.
    … u mnie systemctl wyrzuca nieco inne wartości (Loaded,Active,Main PID,Tasks,CGroup). Ale nie, to mnie zastanawia, tylko ten dubel przedzielony ‚…skipping…’. Nie pamiętam, abym coś takiego widział – o co chodzi? Czy statusy innych service’ów również raportuje w takiej formie?
    ————-
    EDIT … wracając do rzutu błędów z pierwszego postu – może odezwie się ktoś, kto będzie mógł coś konkretnego z tego wyciągnąć. Wygląda na to, że ma problemy z gtk – tylko o co dokładnie chodzi? Może pomoże odinstalowanie gufw, wyczyszczenie konfiguracji, cache’a i ponowna instalacja? Chamskie, ale może warto spróbować.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #6816
    majo
    majo
    Moderator

    Tu zamieściłem log z dzisiejszego uruchomienia systemu, do momentu dwóch pierwszych prób z gufw ( o godz. 08:21:31 i 08:26:13 ) https://pastebin.com/4r4rDxH0

    Tu log z journalctl -f z dwoma próbami z z gufw uruchamiane z poziomu Menu Manjaro
    https://pastebin.com/ctvm8iZf

    Próbowałem reinstalować gufw (bez odinstalowania i usuwania zależności), jednak to nic nie dało.

    Edit (z 14.02)
    Kolejny log z uruchomienia systemu. Próba z gufw, tym razem z poziomu konsoli, o godz. 08:20.
    https://pastebin.com/gr1gFspH

    Manjaro [stable] LTS, Xfce - tego używam

    #6820
    azja
    azja
    Moderator

    … nie jestem w stanie zinterpretować tych logów na satysfakcjonującym poziomie, dlatego przejrzałem je na zasadzie ‚może coś rzuci się w oczy’:
    # microcode updated early to revision 0x29, date = 2013-06-12
    Jeżeli dobrze interpretuję zapis, to data microcode jest podejrzanie nieświeża. Być może wszystko jest w porządku, ale … masz aktualny system (dla porządku musiałem zapytać)?
    # Linux version 4.9.79-1-MANJARO
    Próbowałeś na innym kernel’u, np. 4.15? W ostatnim czasie było spore zamieszanie związane z podatnością procesorów i Linus mógł skupić się, w pierwszej kolejności, na najświeższym kernel’u.
    # i ostatnie, najważniejsze:
    we wszystkich zrzutach z log’ów powtarza się ten sam motyw: Core Dump dwóch procesów – xfce4-taskmanager i python3. Z tego ten drugi wyraźnie wskazuje na libgtk-3 jako źródło problemu. python i gtk – pokrywa się, to z tym, co widzimy w komunikatach błędów, w trakcie próby uruchomienia gufw. Poszedłbym tym tropem – jak Tommy Lee Jones w ‚Ściganym’.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #6823
    majo
    majo
    Moderator

    Tak, system mam aktualny ( 4.9.79-1-MANJARO ), aktualizowany na bieżąco, w rytm aktualizacji [stable].
    Spróbowałem na drugim zainstalowanym kernelu ( 4.4.114-1-MANJARO ) i jest ten sam problem i te same komunikaty błędu.

    Jeśli chodzi o ostatnią wskazówkę, to nie wiem za bardzo co mogę z tym zrobić (tu kończy się moja wiedza).
    Nie widzę w systemie żadnego pakietu libgtk-3.
    Pod hasłem libgtk kryją się 4 pakiety w AUR, których nie mam zainstalowanych.
    Przeinstalowałem 2 zainstalowane pakiety z python3 i xfce4-taskmanager i bez zmian.

    Edit:
    Podczas aktualizacji systemu miałem komunikat:
    Odinstalowałem i zainstalowałem ponownie pakiet intel-ucode, który odnosił się (zgodnie z opisem pakietu) do Microcode, o czym pisałeś (jednak to nic nie pomogło, jeśli chodzi o błąd gufw).
    Z tym pakietem jest coś, czego nie rozumiem z datami. Na stronie https://www.archlinux.org/packages/extra/any/intel-ucode/ z jednej strony jest napisane intel-ucode 20180108-1, co sugeruje, że jest to najnowsza wersja ( i taką pierwotnie miałem).
    Z drugiej strony, w wyniku ponownej instalacji tego pakietu, mam obecnie wersję 20171117-1 (więc nie najnowszą).
    A z trzeciej strony, pakiet jest oznaczony „Flagged out-of-date on 2018-01-23”.

    Manjaro [stable] LTS, Xfce - tego używam

    #6836
    azja
    azja
    Moderator

    libgtk-3.so.0.2200.26 należy do pakietu gtk3. Nie wiem, czy problem leży po stronie gtk czy python’a. Skoro jednak aplikacja, w trakcie uruchamiania się, wykłada się na nich, to moje podejrzenie pada na te elementy. Czy to ich wina (lub któregoś z nich)? Czy przeinstalowanie coś pomoże? A może jest problem z konfiguracją? Albo śmieciami w cache’u? Nie wiem. Ale jestem pewien, że śmierdzi z tej strony i w tym kierunku poszedłbym w poszukiwaniach, gdybym sam miał taki problem i zależałoby mi na jego wyjaśnieniu.
    … starsza wersja microcode, to efekt zamieszania z ostatnimi podatnościami procesorów (poruszaliśmy temat w ostatnich tygodniach). Wygląda na to, że Manjaro wycofało poprawkę (chyba zgodnie z sugestią Intel’a), a Arch zostawił. Nie wiązałbym tego tematu z Twoim problemem.
    … skoro tutaj nie odzywa się nikt, kto miałby odpowiednią wiedzę i był w stanie popchnąć temat do przodu, to poszukaj gdzie indziej: na oficjalnym forum Manjaro, oficjalnym forum Arch’a, polskim forum Arch’a, albo i szerzej.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #6840
    napcok
    napcok
    Administrator
    #6845
    majo
    majo
    Moderator

    Na najnowszym kernelu LTS (4.14.19) problem też występuje.

    Wątki na forum manjaro.org dotyczą innych problemów GUFW, więc tam, na razie, nie piszę.

    Znalazłem natomiast dwa tropy.
    1. Chyba podobny problem (jeśli chodzi o część pokazanych logów) był na forum Antergosa. Jednak okazało się, że jest to problem z Wayland, a ja mam x11.

    2. Natomiast w Archu jest zgłoszony identyczny błąd, jak ten u mnie (zgłoszony ponad rok temu).
    Czy dobrze odczytuję, że nikt, jak na razie, nad tym nie pracuje?
    ( A w konsekwencji, nie mam co się łudzić, że uda mi się rozwiązać ten problem )

    Manjaro [stable] LTS, Xfce - tego używam

    #6886

    michaldybczak
    Forumowicz

    Instalowałem Manjaro 1,5 roku temu i też był taki problem, bo włączałem firewall w gufw, ale nigdy nie startował z systemem, więc to gui jakieś spieprzone jest. Jednak zawsze działało proste:

    sudo systemctl enable ufw
    sudo systemctl start ufw

    I tyle, więc w sumie to nie był jakiś specjalny problem. Jak gui jest oporne to terminal zawsze pomaga.

    #6887
    Robert75
    Robert75
    Forumowicz

    http://www.nibyblog.pl/ufw-czyli-nieskomplikowany-firewall-w-ubuntu-2148.html

    Anarchy Xfce - 64Bit Linux User #621110
    https://anarchy-linux.org/

    #6888
    majo
    majo
    Moderator

    Koledzy michaldybczak i Robert75, dzięki za wskazówki.
    Niestety, mój problem jest inny. UWF działa mi poprawnie, co potwierdzają komendy załączone w pierwszym poście.
    Nie działa natomiast GUFW i być może jest to jakiś poważniejszy bug, zgłoszony (i chyba nierozwiązany) w Archu.

    Manjaro [stable] LTS, Xfce - tego używam

    #6889
    Robert75
    Robert75
    Forumowicz

    Nie mam pojęcia dlaczego Tobie nie uruchamia się GUFW, bo u mnie się normalnie uruchamia, a mamy te same systemy, czyli Manjaro Xfce.

    Anarchy Xfce - 64Bit Linux User #621110
    https://anarchy-linux.org/

    #6891
    majo
    majo
    Moderator

    @robert75
    Tak to właśnie jest z Bug’ami, że nie wiadomo dlaczego, ale czasami pojawiają się problemy :)
    U mnie obecnie nie dochodzi do uruchomienia GUFW, w takiej formie, jak to pokazujesz (choć kilka miesięcy temu wyglądało to u mnie tak, jak teraz u Ciebie).
    Obecnie , po wybraniu ikonki firewalla z poziomu Menu, nie dzieje się nic, a przy próbie uruchomienia GUFW z poziomu konsoli wyskakują błędy: https://pastebin.com/EaP3j2Gi

    Manjaro [stable] LTS, Xfce - tego używam

Oglądasz 15 posty - 1 do 15 (z 32 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.