[SOLVED] Instalacja, system nie uruchamia się z pendrive'a

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Podstawy [SOLVED] Instalacja, system nie uruchamia się z pendrive'a

Ten wątek zawiera 23 odpowiedzi, ma 9 uczestników, ostatnio zmodyfikowany przez azja azja 6 miesięcy, 2 tygodni temu.

Oglądasz 15 posty - 1 do 15 (z 24 ogółem)
  • Autor
    Posty
  • #6902

    shaggy1191
    Forumowicz

    Dzień dobry.
    Odkąd pamiętam używałem systemów Windows (początkowo XP, potem 7). Kilka razu uruchamiałem z pendrive’a dystrybucje Linuxa: Ubuntu, Mint, wczoraj PartedMagic. Od pewnego czasu zastanawiałem się nad tym, czy nie zacząć korzystać z Linuxa na co dzień, ponieważ zaskakiwał mnie on swoją „lekkością” działania.
    Pobrałem obrazy systemów Linux Manjaro w wersji 17.1.5 , ze środowiskiem graficznym Cinnamon oraz XFCE (nie wiedziałem, które będzie dla mnie lepsze). Do utworzenia pendrive’a pobrałem program Unetbootin, dzięki któremu udało mi się uruchomić PartedMagic wczoraj. W tym momencie zaczynają się problemy.
    Po uruchomieniu komputera pojawia się ekran jak na załączniku oznaczonym 1, po wybraniu Deflaut pojawia się ekran jak na załączniku oznaczonym 2 i nic dalej się nie dzieje, jedyne co można zrobić to wyłączyć komputer przytrzymując przycisk zasilania. Po wybraniu Boot: Manjaro pojawia się ekran jak na załączniku oznaczonym 3.
    Znalazłem informację, że program, którego użyłem do tworzenia pendrive’a może być zły. Pobrałem inny: WIN32DiskImager. Utworzyłem pendrive’a. Po ponownym uruchomieniu komputera pojawia się czarny ekran z białym napisem w lewym górnym rogu „Grub loading.”, a w następnym wierszu „Welcome to Grub!”. Zostawiłem komputer na około 30 minut, wyświetlało się nadal to samo.
    Próbowałem z 2 różnymi pendrive’ami (USB 2.0 i 3.0), na porcie USB 2.0 bo na 3.0 w ogóle nie widział, że coś jest podłączone (tak samo było przy instalacji Win7 więc się tym nie zmartwiłem). Próbowałem zarówno na formacie plików NTFS jak i FAT32, exFAT. Próbowałem z odłączonymi wszystkimi peryferiami i na podłączonych. W BIOS-ie nie mam opcji SecureBoot więc jej nie wyłączyłem (na stronie producenta znalazłem informację mówiącą, że musiałbym zainstalować aktualizację BIOS-u aby mój komputer obsługiwał tą opcję, więc myślę, że jest okej).
    System to 64 bitowy Windows 7 Home Premium, zarejestrowany z legalnego klucza (jednak system nie jest oficjalny tylko modyfikowany, nie pobiera niektórych aktualizacji). Sprzęt to: HP Pavilion dv6 6150ew; procesor: Intel Core I5 2410M 2×2,3 (2,6) GHz; grafika: Radeon HD 6770M oraz druga zintegrowana Intela.
    Przepraszam za tak długi post jednak chciałem wszystko dokładnie opisać. Z góry dziękuję za pomoc.

    Załączniki:
    #6905
    aquila
    aquila
    Moderator

    Przeczytaj. Zobacz czy pendrive uruchamia się na innym kompie.

    #6906

    Mojz3sz
    Forumowicz

    Witaj @shaggy1191!
    Z uwagi na fakt, że Manjaro korzysta z obrazów hybrydowych osobiście sugerowałbym użycie programu Rufus jeśli tworzysz bootowalnego pendrive’a z poziomu Windowsa.

    #6908
    azja
    azja
    Moderator

    … używałem wielokrotnie, do ‚wypalania’ PEN’a, Universal USB Installer (UUI) i nigdy nie miałem problemów. Ważne: nie ściągaj systemu za pomocą programu, tylko bezpośrednio ze strony manjaro.org.

    dobreprogramy.pl
    pendrivelinux.com

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #6953

    shaggy1191
    Forumowicz

    Przeczytałem wątek przytoczony przez aquila. Gdy pojawił się ekran jak na screenie 1 nacisnąłem TAB, dopisałem to co było w przytoczonym wątku, nacisnąłem ENNTER, pojawił się ekran jak na screenie 2. Uruchomiłem ponownie, dopisałem drugą z przytoczonych komend, pojawił się ekran jak na screenie 3. Uruchomiłem ponownie, wpisałem po znowu pierwszą z komend, pojawił się ekran jak na screenie 3, każda kolejna próba kończyła się pojawieniem komunikatu z 3.
    Aby odłączyć kartę musiałbym rozłożyć laptopa na części, nie chcę tego robić ponieważ prawdopodobnie coś bym uszkodził. BIOS mam dosyć ubogi, dostarczycielem jest Insyde, wersja to F17.0. Nie ma możliwości odłączenia w nim karty.
    Jeśli ktoś ma jakieś pomysły to chętnie posłucham. Jeśli nie to prosiłbym tylko o łopatologiczne wyjaśnienie, czemu inne dystrybucje (Mint, Ubuntu, PartedMafical) ruszyły bez problemu? (Mint i Ubuntu na OEM Win7, którą miałem dostarczoną z laptopem, PartedMagical na systemie zainstalowanym przeze mnie i czy to może mieć jakiś związek?)
    Spróbuję jeszcze uruchomić dzisiaj inne dystrybucję i dam znać jak poszło.

    #6954
    aquila
    aquila
    Moderator

    Mój link miał dotyczyć tylko wpisu @napcok -a a nie całego wątku. Dalej nie odpowiedziałeś czy ten przez Ciebie pen działa na innym kompie? Czy próbowałeś nagrać ISO innymi programami proponowanymi przez resztę użytkowników w tym wątku?

    #6955

    shaggy1191
    Forumowicz

    Próbowałem Rufus i LinuxLive USB (wiem, że nie był aktualizowany od dawna). we wszystkich przypadkach kończyło się to jak na załączonych screenach. Pliki ISO pobierałem z zakładki „Pobierz” na tym forum. W chwili obecnej nie mam jak sprawdzić, czy utworzony pendriv’e działa na innym komputerze (dam znać jak mi się uda). Debian oraz Arch utworzone Rufusem uruchomiły się, możliwe było rozpoczęcie instalacji.

    #6964

    michaldybczak
    Forumowicz

    Widziałem wiele razy jak zmiana pen drive’a pomogła w problemach z bootem. Musisz potestować czy to pen drive czy to Manjaro, czy program do wypalania iso.

    #6965

    V3ntu
    Forumowicz

    Wybierz opcje sterowników nonfree i w grubie dopisz:
    acpi_osi="Windows 20015"
    lub
    acpi_osi=! acpi_osi="2009"
    Daj znać czy zadziałało

    #6970

    shaggy1191
    Forumowicz

    Widziałem wiele razy jak zmiana pen drive’a pomogła w problemach z bootem. Musisz potestować czy to pen drive czy to Manjaro, czy program do wypalania iso.

    Na samym początku wątku pisałem, że używałem 2 pendrive’ów oraz kilku różnych programów. Później używałem kolejnych programów. Inne dystrybucje działają, co również napisałem.

    Wybierz opcje sterowników nonfree i w grubie dopisz:
    acpi_osi="Windows 20015"
    lub
    acpi_osi=! acpi_osi="2009"
    Daj znać czy zadziałało

    Gdzie mam wybrać opcję nonfree, wyświetlają mi się tylko ekrany jak na schreen’ach? Używałem już tych poleceń, co opisałem:

    Gdy pojawił się ekran jak na screenie 1 nacisnąłem TAB, dopisałem to co było w przytoczonym wątku, nacisnąłem ENNTER, pojawił się ekran jak na screenie 2. Uruchomiłem ponownie, dopisałem drugą z przytoczonych komend, pojawił się ekran jak na screenie 3. Uruchomiłem ponownie, wpisałem po znowu pierwszą z komend, pojawił się ekran jak na screenie 3, każda kolejna próba kończyła się pojawieniem komunikatu z 3.

    #6971
    majo
    majo
    Moderator

    Mam obecnie działające LiveUSB (z Manjaro 16.10.3, XFCE ) utworzone ok rok temu z poziomu Windows XP za pomocą https://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/
    Wcześniej, kilkukrotnie tworzyłem Manjaro LiveUSB za pomocą tego programu i nigdy, z Manjaro, nie było żadnych problemów. Może Tobie też zadziała.

    Manjaro [stable] LTS, Xfce - tego używam

    #6974

    shaggy1191
    Forumowicz

    Mam obecnie działające LiveUSB (z Manjaro 16.10.3, XFCE ) utworzone ok rok temu z poziomu Windows XP za pomocą https://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/
    Wcześniej, kilkukrotnie tworzyłem Manjaro LiveUSB za pomocą tego programu i nigdy, z Manjaro, nie było żadnych problemów. Może Tobie też zadziała.

    Przy tworzeniu pendrive’a pojawia się błąd o niemożliwości znalezienia pliku lub biblioteki, przy odpalaniu takiego pendrive’a wyświetla się komunikat o niemożliwości odnalezienia kernel’a.

    #6975
    majo
    majo
    Moderator

    Hmm..
    Gdy robiłem (kilkukrotnie) LiveUSB Manjaro za pomocą UUI, to cały proces kończył się komunikatem OK (bez błędów).
    Czy na pewno plik .iso nie posiada błędów (tj. czy sprawdziłeś sumy kontrolne sha1 czy md5?) i czy pendrive jest właściwie sformatowany? (najlepiej w FAT32)

    A może te wszystkie programy mają problem z najnowszym wersją instalacyjną Manjaro?
    Możesz spróbować ściągnąć starszą wersję systemu (np.16.10.3), zrobić z niej LiveUSB (za pomocą UUI) i zainstalować Manjaro z tego LiveUSB.
    Przy pierwszym uruchomieniu, system zasygnalizuje Ci, że są nowsze pakiety do zainstalowania, a po tej aktualizacji będziesz już miał Manjaro w najnowszej wersji.

    Manjaro [stable] LTS, Xfce - tego używam

    #6976

    shaggy1191
    Forumowicz

    Problem rozwiązany. Udało mi się uruchomić Manjaro 16.10.3, na razie z pendrive’a. Instalacją prawdopodobnie zajmę się w weekend. Bardzo dziękuję wszystkom za pomoc, zaangażowanie a przede wszystkim cierpliwość. Pozdrawiam.

    #6977
    azja
    azja
    Moderator

    @shaggy1191 -> napisz w jaki sposób uruchomiłeś, co zrobiłeś, jaka porada była skuteczna (a może coś zupełnie spoza wątku). Ktoś, kto będzie szukał informacji, zobaczy, że problem jest rozwiązany, ale rozwiązania nie znajdzie.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 15 posty - 1 do 15 (z 24 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.