Nie startuje mi graficznie linux

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Sprzęt i sterowniki Nie startuje mi graficznie linux

Ten wątek zawiera 43 odpowiedzi, ma 5 uczestników, ostatnio zmodyfikowany przez azja azja 4 miesięcy temu.

Oglądasz 15 posty - 16 do 30 (z 44 ogółem)
  • Autor
    Posty
  • #7688

    pavbaranov
    Forumowicz

    1. Na laptopie – tak, abyś to zawsze widział – przyklej sobie kartkę z napisem: „NIE BĘDĘ KOMBINOWAĆ Z ŻADNYMI STEROWNIKAMI DOPÓKI NIE BĘDĘ WIEDZIEĆ CO ROBIĘ!„. Zainstalowałeś całą pokaźną baterię sterowników do GPU AMD (i to w dwu wersjach), do NVidia, oraz „podstawczak”, czyli VESA. Ten ostatni też ustawiłeś jako sterownik dla Twojego komputera. Swoją drogą, to w jaki sposób MSM podpowiedział Ci, że dla Twojego komputera w ogóle nadają się sterowniki dla AMD i dla NVidii kompletnie nie wiem i raczej sam pomieszałeś.
    2. Twój komputer ma zintegrowaną GPU z CPU i nazywa się on Intel. W przypadku Intela można używać sterownika xf86-video-intel (są z nim niekiedy kłopoty), albo nie używać w ogóle żadnego sterownika „zewnętrznego” i zdać się na to co wbudowane w kernel, czyli modesettings (tak jest domyślnie np. w Debianie, Ubuntu i pochodnych, w Fedorze i zalecane przez KDE). Nie używam obecnie komputera z Intelem i nie używam GNOME, ale skoro to domyślne środowisko Fedory, to chyba wiedzą co robią.
    3. Po wejściu do trybu konsolowego – odinstaluj wszystkie sterowniki wideo niepotrzebne w Twoim systemie. Mają one nazwy o strukturze xf86-video-*, gdzie w miejscu gwiazdki jest nazwa sterownika (ati, amdgpu, nouveau, vesa). Nie wiem co masz tam poinstalowane jeszcze, ale usuń i to. Sprawdzisz:
    pacman -Qs xf86-video
    Pojawi Ci się cała lista.
    Usuwając wyczyść ich pliki konfiguracyjne:
    pacman -Rn nazwa
    Usuń również wszystkie paczki z nazwą „vulkan”, zawierające w nazwie „vdpau”, „libva-mesa” itp. To nie są sterowniki dla Twojej karty. Akceleracją możesz się pobawić jak w ogóle system Ci wystartuje i w innym wątku.
    4. Możesz również usunąć paczkę xf86-video-intel – system winien wystartować na modesetting. Nie jest to konieczne, ale może warto sprawdzić. Zawsze możesz doinstalować.
    5. W zasadzie porządki zrobione i po restarcie system winien się obudzić.
    6. Przed punktem 5 – choć nie zalecam – możesz użyć polecenia mhwd. Nie używam tego od bardzo wielu lat (tak z 5) i nawet już nie pamiętam jak to działa. Podręcznik w wiki. Niemniej – tak jak mówię – na razie absolutnie nie polecam tego.
    7. Jeśli zdecydujesz się pominąć punkt 4, a system mimo wszystko nie podniesie grafiki – konsola i doinstaluj tę paczkę, potem restart.
    Zdaj relację i miejmy nadzieję, że się to podniesie i nie narobiłeś w systemie więcej szkód.

    A na przyszłość – oprócz najważniejszego punktu 1 – nie używaj do instalacji, aktualizacji pamac, a zacznij używać pacman. Jeśli tego użyłeś przy instalacji tych paczek, to wywołuje on automatycznie pacmana z opcją –noconfirm co być może jest wygodne, ale tylko i wyłącznie wówczas, gdy ktoś, kto je wywołuje wie co robi. Jeśli to automat, to twórca programu winien w końcu pójść po rozum do głowy. Jeśli to jakiś hook w Manjaro – również. Akurat pacman jest dobrze opisany, ma dobry manual, są przykłady. Podstawowe polecenia do zapamiętania w 5 minut, a nadto można sobie porobić aliasy. Bonus – mniej problemów.

    #7689
    azja
    azja
    Moderator

    … zrób porządki, jak radzi @pavbaranov, boś chłopie namieszał. A na przyszłość:
    # driver’y do grafiki, to krytyczny element w Linux’ie – nie baw się nimi, nie experymentuj, modyfikuj jeżeli wiesz co robisz;
    # votum separatum, do listy zaleceń mojego przedmówcy – Manjaro, to nie Arch, dlatego do modyfikacji (usuwania, dodawania, wymiany, etc) sterowników do grafiki używaj Manjaro Linux Hardware Detection:
    mhwd w trybie text’owym
    Konfiguracja Sprzętowa w trybie graficznym
    https://wiki.manjaro.org/index.php?title=Mhwd
    https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards
    … jeżeli będziesz używał mhwd w sposób prawidłowy, to w większości przypadków nie będziesz miał problemów. Jeżeli chcesz, to robić ręcznie – najpierw porządnie przerób teorię.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7690

    pavbaranov
    Forumowicz

    @azja – Wiem, o istnieniu mhwd. Manjaro to jednak Arch z nadbudówkami. Tutaj celowo zaproponowałem rozwiązanie via pacman, aby być pewnym, że zostanie dokonane dokładnie to, co wykonane ma zostać i w sposób dokładnie zamierzony. Dopiero potem można się bawić w mhwd.

    #7691
    azja
    azja
    Moderator

    @pavbaranov -> całkowita zgoda. Przy tym bałaganie, trudno byłoby ogarnąć temat za pomocą mhwd – ręczne robótki, są bardziej na miejscu. Jednak na zaś – mhwd jest jednym z rozwiązań wyróżniających Manjaro spośród innych Arch-like; jest narzędziem systemowym, tworzonym zgodnie z założeniami tegoż systemu, więc … używać. Żyjemy w czasach, w których automatyczne rozpoznawanie urządzeń i instalowanie do nich sterowników, obecne jest powszechnie (od ponad 20 lat!). Oczywiście, daleki jestem od zabraniania komukolwiek – jeżeli jesteś dorosły, nikogo nie krzywdzisz, wiesz co robisz, to dlaczego nie. Sam często postępuję w ten sposób, ale świadom jestem tego, że rezygnuję (z jakiegoś powodu) z narzędzia, udogodnienia, że – jak inż. Karwowski – piorę ręcznie, bo mnie to relaksuje :-)

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7692

    Artur
    Forumowicz

    Ok. To użyłem komendy

    pacman -Qs xf86-video

    Wyskoczyło mi 5 wyników:
    np:

    Local/xf86-video-amdgpu 18.0.1-1 (xorg-drivers)

    Potem to samo z ATI, Intel, nouveau i vesa.

    Chce to odinstalować to wpisuję:

    sudo mhwd -r xf86-video-amdgpu

    Wyskakuje mi:

    Invalid use of option: -r/--remove
    
    Usage: mhwd [OPTIONS] <config(s)>

    A następnie litania opcji jakie mogę zastosować do tego polecenia. Nie chce się nic usuwać…

    Próbowałem też komend:

    Najpierw:

    mhwd -li

    To mi wyskoczyło:

    video-vesa
    video-linux

    A następnie aby usunąć:

    sudo mhwd -r [nazwa]

    Też z marnym skutkiem…

    Co robić?

    #7693
    majo
    majo
    Moderator

    @artur
    do usuwania pakietów używaj komendy sudo pacman -Rn NAZWA_PAKIETU_DO_USUNIĘCIA

    Manjaro [stable] LTS, Xfce - tego używam

    #7694
    azja
    azja
    Moderator

    mhwd zostaw na później, jak już uprzątniesz bałagan. Teraz, do usuwania pakietów (ZBĘDNYCH) używaj poleceń pacman’a, czyli na przykład:
    sudo pacman -Rn xf86-video-ati
    Odinstalujesz, tą komendą, pakiet z driver’ami do ATI i jego pliki konfiguracyjne.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7695

    Artur
    Forumowicz

    Okej. Zrobiłem tak jak napisaliście.

    W niektórych przypadkach pojawia się:

    sprawdzanie zależności
    błąd:nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
    ::gst-plugins-bad:usuwanie vulkan-icd-loader łamie zależności 'vulkan-icd-loader' 
    ::lub placebo:usuwanie vulkan-icd-loader łamie zależności 'vulkan-icd-loader'

    Teraz system zatrzymuje mi się na ekranie gdzie pisze:

    starting version 238
    /dev/sda1: clean, 559377/14712832 files, 37039922/58839758 blocks

    Usunąłem jak leci wszystkie sterowniki zaczynające się od xf86 więc usunęło też i xf86-video-intel. A nie sprawdzałem czy z tym sterownikiem będzie działać…

    #7696

    pavbaranov
    Forumowicz

    Tam, gdzie krzyczy, że są jakieś zależności i dlatego nie może usunąć to zostaw taką paczkę.

    Uruchom system, ale przy jego uruchamianiu wejdź do GRUBego i skasuj słowo „quiet”, podaj albo ostatnią linijkę, na jakiej się zatrzymuje, albo znów dziennik (masz wyżej z journalctl) – będzie nawet lepiej.

    #7697
    azja
    azja
    Moderator

    … pakietu vulkan-icd-loader potrzebują gst-plugins-bad i libplacebo. Dlaczego chciałeś go odinstalować? Co usunąłeś – możesz przedstawić listę? Możesz przejść na inną konsolę (np. Ctrl+Alt+F2) i zalogować się?
    ————-
    EDIT…no tak, nie masz pewnie teraz żadnych driver’ów do grafiki.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7698

    pavbaranov
    Forumowicz

    … pakietu vulkan-icd-loader potrzebują gst-plugins-bad i libplacebo. Dlaczego chciałeś go odinstalować?

    Bo tak go poinstruowałem.

    EDIT…no tak, nie masz pewnie teraz żadnych driver’ów do grafiki.

    GPU Intela nie wymaga żadnego sterownika grafiki! Bez xf86-video-intel ma działać na wbudowanym w każdy kernel modesetting. Tak działa to w Debianie, Ubuntu i pochodnych, w Fedorze… Sterownik Intela, niestety, jest bardzo zaniedbany i jest wieczną betą. Niektórym dystrybucjom skończyła się cierpliwość dla wiecznie niedziałającego sterownika.

    PS: @azja – Proponuję polemiki między nami przenieść na jakiś IRC, bo ktoś, komu chcemy pomóc kota dostanie. Jestem zwykle na freenode archownia.pl, archlinux.org.pl, dobreprogramy.pl, polaur (ale to dotyczy wyłącznie niemal spraw tego repozytorium) i archlinux-pl (ale tu jest zbyt wielu). Możemy też pogadać przez IRC indywidualnie. Na kanale manjaro.pl nigdy mnie już nie będzie, zatem tu nie szukaj.

    #7699

    Artur
    Forumowicz
    #7700
    azja
    azja
    Moderator

    @pavbaranov -> vulcan: no racja, przeoczyłem. IRC: rzadko bywam, ale jak zajrzę, to poszukam :-)

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7701

    pavbaranov
    Forumowicz

    @artur – namieszałeś totalnie :)
    Poprosimy jeszcze o zawartość /etc/X11/xorg.conf.d oraz /usr/share/X11/xorg.conf.d – jeśli są tam jakieś pliki – ich zawartość.
    System próbuje wystartować na vesa, którego nie masz (i to m.in. jest bycze narzędzie mhwd :)).

    #7702
    azja
    azja
    Moderator

    … to jest tylko opinia, bo nie wiemy dokładnie, co działo się w systemie, ale moim zdaniem obecny stan nie jest efektem działania mhwd (mało prawdopodobne), tylko ruchów użytkownika, pomijającego istniejące mechanizmy systemowe i nie stosującego się do ogólnych zasad. mhwd domyślnie instaluje video-vesa – a dokładniej rzecz biorąc, nie spotkałem się dotychczas z sytuacją, aby po instalacji systemu, nie było vesa’y.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 15 posty - 16 do 30 (z 44 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.