Niewyjaśnione zniknięcia zawartości partycji

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Inne Niewyjaśnione zniknięcia zawartości partycji

Ten wątek zawiera 21 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez majo majo 4 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 22 ogółem)
  • Autor
    Posty
  • #7627
    majo
    majo
    Moderator

    Właśnie odkryłem, że zawartość całej partycji sda5, na której była zainstalowana zapasowa dystrybucja Manjaro (, którą chciałem na dniach reinstalować, bo prawie nie działała), została wyczyszczona.

    Nie ma kompletnie pojęcia, co i kiedy wyczyściło tą partycję.
    W koszu są tylko 4 inne, świadomie usunięte przeze mnie pliki.
    Ja NA PEWNO jestem na tyle ostrożny i świadomy, że nie zrobiłem tego nieumyślnie (ani umyślnie).

    Jeszcze wczoraj wieczorem porównywałem wybrane pliki w tej partycji z odpowiednimi plikami w mojej głównej instalacji Manjaro na sda2.
    W międzyczasie:
    – nie robiła mi się żadna aktualizacja systemu, ani nie instalowałem nowych programów,
    – 2 razy uruchamiałem liveUSB Manjaro: w wersji 16.10.3 oraz w wersji 17.1.10, (aby zobaczyć, czy jest tam możliwość instalacji Manjaro UEFI bez instalowania GRUBa); za każdym razem nie robiłem niczego innego, niż wstępne wskazanie innej, obecnie pustej partycji sdb2, a po sprawdzeniu, że nie ma opcji instalacji Manjaro UEFI bez GRUBa(?!), kończyłem proces instalacji poprzez opcję „Anuluj” (niczego nie formatując ani nie instalując) i wychodziłem z LiveUSB.

    Już kiedyś miałem przypadek niewyjaśnionego zniknięcia danych, z tym, że wtedy zniknęło mi ok 50% zawartości partycji, a obecnie 100%.

    Czy macie pomysł, co mogło się stać?
    Ew. gdzie powinienem szukać śladów?

    Edit:
    Parametry SMART dysku: Ocena ogólna: dysk jest OK.
    Extended Self-Test – czas 85 min – (wykonany pakietem GSmartControl) -rezultat: „Completed without Error”.

    Manjaro [stable] LTS, Xfce - tego używam

    #7628

    pavbaranov
    Forumowicz

    Nie jest mi znane narzędzie, które potrafiłoby zidentyfikować co dokonało wykasowania pliku, zatem wszystko inne jest jedynie gdybaniem. Sprawdź sobie jakimś clamav itp., czy jakiś syf nie siedzi Ci w komputerze, ale wątpię, by przyniosło to jakiś efekt. Samych powodów dlaczego tak się stało może być od metra i trochę. Od jakiegoś złośliwego skryptu/wirusa/malware’u, po jakieś działania (nie ma znaczenia, czy świadome, czy nie) użytkownika (i zwykle na to w takich przypadkach stawiam).

    #7629
    azja
    azja
    Moderator

    … nie żebym miał jakiś pomysł, ale ciekaw jestem, czy partycja jest dziewiczo pusta, czy coś zostało? Piszesz o jakichś plikach w koszu – rozumiem, że chodzi o kosz na wyczyszczonej partycji (a więc nie dziewicza). Usuwałeś je dawno temu, gdy system jeszcze działał?

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7631
    majo
    majo
    Moderator

    Byłem mało precyzyjny. Mówiąc w „koszu”, miałem na myśli ikonkę kosza na pulpicie, gdzie widoczne są usunięte pliki ze wszystkich partycji (4 znajdujące się tam pliki były usunięte z innej partycji niż sda5).
    Feralna partycja sda5 jest całkowicie pusta.

    Przeskanowałem także cały dysk (co trwało z 3 godz.) i nie ma żadnego wykrywalnego malware.

    Biorąc pod uwagę, że była to partycja systemowa, z plikami których usunięcie wymaga uprawnień administratora, podejrzewam że czyszczenie zostało zrobione, w wyniku jakiego błędu, przez instalator Manjaro :(

    Manjaro [stable] LTS, Xfce - tego używam

    #7632
    azja
    azja
    Moderator

    … gdybyś, jakimś cudem, miał gdzieś informację o UUID wyczyszczonej partycji sprzed czyszczenia, to moglibyśmy porównać go z aktualnym. Ale pewnie nie masz. Gdyby był inny, to wskazywałoby na to, że partycja jest po formacie. Na to stawiam – prawdopodobnie poszedłeś o jeden krok za daleko, podczas badania instalatora.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7634
    majo
    majo
    Moderator

    Etykieta, UUID, punkt montiowania – wszystko wygląda identycznie, jak kilka miesięcy temu:

    lsblk -f 
    NAME   FSTYPE LABEL    UUID                                 MOUNTPOINT
    sda                                                         
    ├─sda1 vfat            DFDC-27CF                            /boot/efi
    ├─sda2 ext4   M        79492466-7c01-4f91-93b6-d7bc1a79f22d /
    ├─sda3 swap            4a557fab-5124-49d5-b531-2d023b88efef [SWAP]
    ├─sda4 ext4   testy24g ccb66e9c-28a3-407a-9e98-33cdfc33a105 /run/media/ja/testy2
    ├─sda5 ext4   M2r16g   c0fe9982-bfcf-43b7-a26e-d480011ed2a0 /run/media/ja/M2r16g
    ├─sda6 ext4   bd       84e26864-1cb9-4bd7-9cfd-915a847f1859 /run/media/ja/bd
    └─sda7 ext4   slit     f9e1a6e3-9ab1-4e97-ae1f-1d0f953d5ed4 /run/media/ja/slit

    Edit:
    Wykluczam możliwość pomyłki z mojej strony:
    1. Byłem świadomy tego co robiłem.
    2. Właśnie żeby nic nawet przypadkowo nie namieszać, sprawdzałem instalator na innej, pustej partycji sdb2.

    Manjaro [stable] LTS, Xfce - tego używam

    #7636
    azja
    azja
    Moderator

    … hmmm, właśnie doszedłem do końca krótkiej listy pomysłów.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7637
    majo
    majo
    Moderator

    A jeśli nie instalator, to może prześladuje mnie (teraz i kiedyś) jakiś niewykryty dotąd błąd ext4? (obie partycje były w ext4)

    Manjaro [stable] LTS, Xfce - tego używam

    #7638
    azja
    azja
    Moderator

    … lekko popuszczając wodze, ale nie odrywając się od ziemi, można by znaleźć mnóstwo potencjalnych powodów. Dlatego prostota (przede wszystkim prostota głupcze; KISS; nie należy mnożyć bytów ponad potrzebę; oraz wiele innych i cennych złotomyśli) jest efektywniejsza, bo generuje mniej powodów do zmartwień i pozwala na szybszą diagnozę.
    … obserwuj i kojarz fakty, bo być może coś rzuci Ci się w oczy. Poza tym, zastanów się nad sprzętowym rozdziałem produkcyjnej instalacji (która ma ciężko pracować na co dzień i być pewną i stabilną) od pozostałych (rezerwowych, testowych, etc.). Wbrew pozorom, taki układ jest prostszy i praktyczniejszy na dłuższą metę.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #7645

    pavbaranov
    Forumowicz

    @majo – Prawdopodobieństwo, że na kilka ładnych milionów użytkowników systemu plików ext4 przez całe lata jedynie u Ciebie objawił się jakiś jego błąd – choć nie jest wykluczone – jest bardzo mizerne. 99,99% sytuacji, jakie opisałeś są wynikiem wadliwego… działania użytkownika. Z całym szacunkiem, ale masz tę instalację nadmiernie przekombinowaną i najprawdopodobniej jej utrzymanie przez Ciebie jest źródłem większości Twoich problemów z GRUBym, ze „znikającymi” plikami itp. Uprość to – tak jak radzi @azja i poniekąd od dłuższego czasu również ja, a problemy znikną. Przynajmniej te.
    Na Twoje pytanie z pierwszego wątku nie ma absolutnie żadnej, sensownej odpowiedzi oprócz jednej: skoro nikt inny użytkujący Manjaro, ext4 oraz Calamares nie zasygnalizował takiego błędu, dysk wydaje się być sprawny, a komputer nie jest dotknięty żadnym świństwem, to masz do wyboru:
    1. coś się przyplątało, wykasowało partycję i ulotniło się jak UFO,
    2. sam popełniłeś jakiś błąd.
    Prawdopodobieństwo drugiego jest niemalże graniczące z pewnością.

    #7647
    majo
    majo
    Moderator

    @pavbaranov
    Wymienione prze Ciebie dwie opcje wykluczam na 100% w tym przypadku (bez żadnego marginesu).
    Co natomiast jest prawdopodobne, to jakiś bardzo rzadki błąd, który pojawia się u mnie w połączeniu kilku z poniższych czynników:
    – aktualna instalacja Manjaro na moim PC (choć nie jest wcale skomplikowana – korzystam w 99 % w głównego Manjaro na sda2)
    – specyficzny sprzęt z którego korzystam i firmware UEFI (który, jak już wyszło, w nietypowy sposób interferuje z Manjaro, m.in. nie działa efibootmgr -v),
    – ext4
    – instalator Manjaro 16.10.3 lub 17.1.10

    Manjaro [stable] LTS, Xfce - tego używam

    #7648

    pavbaranov
    Forumowicz

    Co natomiast jest prawdopodobne, to jakiś bardzo rzadki błąd, który pojawia się u mnie w połączeniu kilku z poniższych czynników:
    – aktualna instalacja Manjaro na moim PC (choć nie jest wcale skomplikowana – korzystam w 99 % w głównego Manjaro na sda2)
    – specyficzny sprzęt z którego korzystam i firmware UEFI (który, jak już wyszło, w nietypowy sposób interferuje z Manjaro, m.in. nie działa efibootmgr -v),
    – ext4
    – instalator Manjaro 16.10.3 lub 17.1.10

    Jeśli chodzi o pierwszą opcję, to do niedawna nie miałeś tego nieskomplikowanego: co najmniej dwie instalki Manjaro, z pełnym GRUBym i EFI. To prędzej czy później musi posypać system (nawet przez nieuwagę), czego zresztą doświadczyłeś.
    Opcja druga – nie wiem nic o „specyficznym sprzęcie” z którego korzystasz, bo nic na ten temat nie pisałeś bodaj nigdy. Jeśli masz jakieś podejrzenia do UEFI (choć nie wyobrażam sobie, by przez firmware wykasowało Ci partycję), to odpowiedz sobie na pytanie czy musisz korzystać z UEFI? W zasadzie wyłącznie wówczas, jeśli masz Windows (i bodaj MacOS), który jego wymaga. Jeśli nie, to może warto uruchomić opcję „legacy” (lub podobnie) w BIOSie i pozbyć się jednego z potencjalnych problemów.
    Ext4 – niemalże na 100% wykluczam ja. Brak zgłoszeń o samoczynnym „skasowaniu” (przy okazji to było skasowanie plików, czy sformatowanie partycji, bo to różnica, choć w tym momencie nie wiem jak do tego dojść oprócz jednego – drugie trwałoby bardzo krótko, pierwsze potrafi zająć nieco czasu komputerowi) zawartości całej partycji i to wyłącznie jednej, z pozostawieniem nienaruszonych innych (przynajmniej nic o tym nie piszesz, zatem domniemuję, że te nie zostały naruszone) raczej wyklucza błąd w ext4.
    Także o takim – samoczynnym – działaniu Calamares nie słyszałem. Co innego, jeśli tak sobie zażyczył użytkownik, ale wówczas to nie błąd Calamares, a pomyłka użytkownika – jak to napisał @azja – mogłeś pójść z tym uruchamianiem Calamares za daleko (w sumie, to prościej było się spytać – nie znam instalatora linuksa (w tym Calamares), który wymusza instalację GRUBego, czy innego jego odpowiednika).
    Jeszcze jedno mi przychodzi do głowy. Otóż udev ma niekiedy problem z prawidłowym nadaniem nazw dyskom (zamiast sda jest sdb i vice versa). Jeśli tak wystąpiło w Twoim przypadku i nie sprawdziłeś jaka to w istocie partycja, na której działasz (czyli czy na pewno to jest /dev/sdb Twojego komputera widziane przez Twój system „podstawowy”; zob.: For example, if the machine has two hard drives, /dev/sda may randomly become /dev/sdb.), a tylko oparłeś się na tym, co pokazał Ci Calamares, to mogło dojść do nieświadomego błędu.

    #7649
    majo
    majo
    Moderator

    Otóż udev ma niekiedy problem z prawidłowym nadaniem nazw dyskom (zamiast sda jest sdb i vice versa). Jeśli tak wystąpiło w Twoim przypadku i nie sprawdziłeś jaka to w istocie partycja, na której działasz (czyli czy na pewno to jest /dev/sdb Twojego komputera widziane przez Twój system „podstawowy”; zob.: For example, if the machine has two hard drives, /dev/sda may randomly become /dev/sdb.), a tylko oparłeś się na tym, co pokazał Ci Calamares, to mogło dojść do nieświadomego błędu.

    Skoro tak by było, to rzeczywiście, można było się dać się oszukać. Choć w tym przypadku nie robiłem żadnej operacji do końca (kończyłem opcją „anuluj”). Poza tym wycięło mi zawartość sda5, podczas gdy ja testy robiłem na sdb2 (jak rozumiem, ten błąd udev, jeśli by się pojawił, wyciąłby partycję sda2).

    Manjaro [stable] LTS, Xfce - tego używam

    #7650

    pavbaranov
    Forumowicz

    No raczej chyba w istocie wówczas sda5 winno się pojawić jako sdb5, a nie sdb2.
    Mniejsza o to. Nie rozwiążemy tego. I nie ujmując Tobie broń boże niczego, sugerowałby po prostu większą rozwagę i uwagę przy dokonywaniu jakichkolwiek czynności, które mogą Ci zdemolować dysk/partycję. I mówię to również z własnego doświadczenia i to nie tylko, gdy byłem świeżym użytkownikiem linuksa, ale nawet i po wielu latach zaliczyłem podobną wpadkę. I absolutnie nie byłem świadom tego, że zrobiłem coś źle.
    Ode mnie: oprócz propozycji uproszczenia sobie systemu, zainstalowania na nim wyłącznie tego co potrzebne i niezbędne do używania (wszak ewentualny drugi system możesz sobie jeśli go potrzebujesz zainstalować nawet na pendrive – wystarczy 16GB co nie jest jakimś problemem w obecnych czasach) oraz zwracania większej uwagi i robienie wyłącznie tego, czego jest się absolutnie pewnym, jeśli chodzi o operacje na dyskach, jak również rozważenie konieczności stosowania UEFI (skoro Twoim zdaniem problematyczne) niczego już nie uzyskasz. I raz jeszcze: nie ma absolutnie żadnej możliwości odpowiedzenia Ci na pytanie dlaczego tak się stało, jak opisałeś. Dla mnie EOT.

    #7651
    azja
    azja
    Moderator

    … każdy experyment na żywym organizmie wiąże się z ryzykiem. Jeżeli, w takich okolicznościach, nie chcesz / nie możesz odłączyć dysku nie biorącego udziału w wydarzeniu, to wyłącz go w BIOS’ie, aby nie był widoczny. W przeciwnym wypadku musisz liczyć się z realnym ryzykiem. Zdobyłeś cenne doświadczenie po promocyjnej cenie, bo nie utraciłeś (chyba) unikalnych danych. Farciarz.

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

Oglądasz 15 posty - 1 do 15 (z 22 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.