NVidia GeForce 7600 GT, Cinnamon problem

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Sprzęt i sterowniki NVidia GeForce 7600 GT, Cinnamon problem

Ten wątek zawiera 38 odpowiedzi, ma 4 uczestników, ostatnio zmodyfikowany przez Robert75 Robert75 1 rok, 3 miesięcy temu.

Oglądasz 15 posty - 1 do 15 (z 39 ogółem)
  • Autor
    Posty
  • #2448
    Robert75
    Robert75
    Forumowicz

    Witam wszystkich. Mam zainstalowanego Manjro Cinnamon. I już podczas instalacji występował problem, ponieważ system nie chciał się instalować z normalnego trybu tylko jedynie z trybu start(non-free drivers) co za tym idzie podczas aktualizacji systemu sam pobrał stery do mojej karty graficznej która to: NVidia GeForce 7600 GT. I tu jest problem po skonfigurowaniu i zapisaniu ustawień NVidii X server setting, po restarcie grafika nie startuje wraz z systemem, muszę wtedy uruchomić NVidia X server setting to kolory wracają. Nie wiem dlaczego tak się dzieje.

    Manjaro Xfce Linux User #621110

    #2449
    aquila
    aquila
    Moderator

    Witam
    Pokaż:
    inxi -SG
    Może trzeba zainstalować starszą wersję NVidia albo przejść na sterowniki free.

    #2450
    Robert75
    Robert75
    Forumowicz

    Kiedy zainstalowałem stery free to X Server przestał działać.

    Załączniki:

    Manjaro Xfce Linux User #621110

    #2452
    aquila
    aquila
    Moderator

    Spróbuj zainstalować nowsze sterowniki NVidii i zobacz czy występuje ten sam problem.
    Poczytaj o tym.

    Ps: 1. Wrzucaj tutaj nie screeny tylko wyniki komend z konsoli w znacznikach code.
    2. Nie opisuj swojego problemu na dwóch wątkach.

    #2457
    Robert75
    Robert75
    Forumowicz

    Nie będę kombinował z nowymi sterami bo już 2 razy musiałem stawiać system na nowo. Znalazłem wyjście może trochę prymitywne ale co tam. Po prostu NVidie X server setting umieściłem w programach startowych i za każdym razem startuje mi X server. Trochę to przeszkadza bo za każdym razem na pulpicie pojawia mi się X server i muszę go zamykać. Ale dzięki temu mam kolory. Ps: Dzięki za uwagę apropo tego screena, ale co Forum to inne działania.

    Manjaro Xfce Linux User #621110

    #2467
    Robert75
    Robert75
    Forumowicz

    @aquila: Wszedłem na tą stronę którą mi poleciłeś i zainstalowałem stery free, i efekt był tragiczny wszystko na pulpicie mi się powiększyło bez możliwości korzystania z systemu. Byłem zmuszony instalować system od nowa.

    Manjaro Xfce Linux User #621110

    #2468

    michaldybczak
    Forumowicz

    I jaki efekt reinstalki? Czy teraz działa jak należy czy ten sam problem?

    #2471
    Robert75
    Robert75
    Forumowicz

    To znaczy dalej stery NVidii nie startują z systemem. Spróbuje zainstalować wyższy kernel może to pomoże.

    Manjaro Xfce Linux User #621110

    #2474
    Robert75
    Robert75
    Forumowicz

    I jest lipa. Próbowałem z kernelem 4.8 jak i z 4.9 jest ten sam efekt. Szkoda gdyby stery grafiki startowały razem z systemem to byłby dla mnie system idealny, ponieważ Manjaro coraz bardziej mi odpowiada. Ale cóż zawsze znajdzie się jakieś ale. Ale tu są jakieś konflikty, może to ma wpływ.` [robson@amd ~]$ mhwd -l -d
    ——————————————————————————–
    > PCI Device: /devices/pci0000:00/0000:00:0f.0/0000:07:00.0 (0300:10de:0391)
    Display controller nVidia Corporation GeForce 7600 GT
    ——————————————————————————–
    > INSTALLED:

    NAME: video-nvidia-304xx
    ATTACHED: PCI
    VERSION: 2016.04.25
    INFO: Closed source NVIDIA legacy drivers for linux.
    PRIORITY: 3
    FREEDRIVER: false
    DEPENDS: –
    CONFLICTS: video-hybrid-intel-nvidia-bumblebee video-nvidia video-nvidia-340xx video-hybrid-intel-nvidia-340xx-bumblebee
    CLASSIDS: 0300 0302
    VENDORIDS: 10de

    > AVAILABLE:

    NAME: video-nvidia-304xx
    ATTACHED: PCI
    VERSION: 2016.04.25
    INFO: Closed source NVIDIA legacy drivers for linux.
    PRIORITY: 3
    FREEDRIVER: false
    DEPENDS: –
    CONFLICTS: video-hybrid-intel-nvidia-bumblebee video-nvidia video-nvidia-340xx video-hybrid-intel-nvidia-340xx-bumblebee
    CLASSIDS: 0300 0302
    VENDORIDS: 10de

    NAME: video-nouveau
    ATTACHED: PCI
    VERSION: 2016.01.28
    INFO: X.org nouveau video driver. Standard open source driver for nvidia graphic cards.
    PRIORITY: 2
    FREEDRIVER: true
    DEPENDS: –
    CONFLICTS: video-hybrid-intel-nouveau-bumblebee
    CLASSIDS: 0300 0302
    VENDORIDS: 10de

    NAME: video-nv
    ATTACHED: PCI
    VERSION: 2012.09.18
    INFO: X.org nv video driver. Standard open source driver for NVidia graphic cards.
    PRIORITY: 1
    FREEDRIVER: true
    DEPENDS: –
    CONFLICTS: –
    CLASSIDS: 0300
    VENDORIDS: 10de

    NAME: video-vesa
    ATTACHED: PCI
    VERSION: 2012.09.18
    INFO: X.org vesa video driver.
    PRIORITY: 0
    FREEDRIVER: true
    DEPENDS: –
    CONFLICTS: –
    CLASSIDS: 0300
    VENDORIDS: *

    Warning: no configs for USB devices found!
    [robson@amd ~]$

    Manjaro Xfce Linux User #621110

    #2476

    pavbaranov
    Forumowicz

    Co to znaczy, że „stery grafiki nie startują razem z systemem”? Z podanego przez Ciebie listingu wynika, że jak najbardziej „startują”.
    Poprawnie skonfiguruj sterownik. W zależności od tego, czy w ogóle startuje Ci środowisko graficzne, czy nie, masz dwie możliowści. W pierwszym przypadku możesz skorzystać z Manjaro Settings Manager oraz narzędzia dostarczanego przez NVidię. W drugim przypadku masz mhwd oraz dobrze opisaną instalację i konfigurację sterowników własnościowych NVidii w wiki Archa.

    #2477

    michaldybczak
    Forumowicz

    Robisz coś źle. Podejrzewam, że masz hybrydową grafikę. Na takim kompie nie instalujesz driverów nvidii, nie będzie się system ładował. Wiem to z doświadczenia. Musisz zainstalować bumblebee. Przy normalnej instalacji Manjaro samo to robi, ale przy edycji NET, to ty musisz to zrobić. Najepiej się zdać na automatyzm Manjaro, po prostu wejdź do tty i wykonaj komendę:

    sudo mhwd -a pci nonfree 0300

    Zrebootuj i wszystko powinno działać, bo Manjaro zainstaluje ci bumbleebee czy inne odpowiednie sterowniki.

    #2478
    Robert75
    Robert75
    Forumowicz

    Niestety to polecenie nie działa.`[robson@amd ~]$ sudo mhwd -a pci nonfree 0300
    [sudo] hasło użytkownika robson:
    Niestety, proszę spróbować ponownie.
    [sudo] hasło użytkownika robson:
    > Skipping already installed config ‚video-nvidia-304xx’ for device: 0000:07:00.0 (0300:10de:0391) Display controller nVidia Corporation GeForce 7600 GT
    [robson@amd ~]$

    Manjaro Xfce Linux User #621110

    #2481

    michaldybczak
    Forumowicz

    Działa. Pierwsza linijka tylko dała ci znać, że źle wpisałeś hasło. Potem daje ci znać, że już masz co trzeba, więc nic to nie dało.

    Ta komenda instalowała ci własnościowe sterowniki i te właśnie masz. Otwarte sterowniki ponoć już próbowałeś.

    Wygląda na to, że nie masz jednak hybrydowej grafiki, tylko tą kartę nvidii.

    Jeśli ani własnościowe, ani otwarte sterowniki nic nie dają, to znaczy, że problem pewnie leży gdzie indziej, może w X albo w jakichś brakach pakietów, ich złej konfiguracji, prawach dostępu albo skorumpowanych plikach.

    Instalowałem Manjaro Cinnamon na jednym laptopie i tam chodził mi perfekcyjnie, ani jednego problemu.

    Jeszcze sprawdziłbym sumę iso, z którego instalowałeś system. Jeśli jest ok, wszedłbym jeszcze raz do wersji live. Jeśli ona działa to w teorii po instalacji tak samo powinno działać, chyba że pochrzaniłeś typy tabeli partycji czy inne sprawy instalacyjne.

    Co jakiś czas instalacja może się skorumpować i być wadliwa, ale wtedy po reinstalce problemy znikają. Jeśli występują ponownie a suma kontrolna jest ok, to znaczy, że albo wybrałeś jakąś błędną opcję, albo jest jakiś konflikt na poziomie sprzętu.

    EDYCJA: Spróbuj inną edycję Manjaro, może coś poszło nie tak przy kompilacji ostatniej wersji Manjaro Cinnamon i przez to u ciebie coś nie gra. Jeśli wszystkie edycje Manjaro nie chcą chodzić na tym sprzęcie to wiadomo, że to już problem hardware.

    #2484
    Robert75
    Robert75
    Forumowicz

    Podczas instalacji z normalnego trybu instalator mi się wyłączał, dopiero gdy zaznaczyłem drugą opcje tzn. start(non-free drivers) wtedy instalacja przebiegła prawidłowo. Trochę dziwne nie uważasz.

    Manjaro Xfce Linux User #621110

    #2486

    pavbaranov
    Forumowicz

    Skorzystaj z wiki Archa – kilka postów wyżej.

Oglądasz 15 posty - 1 do 15 (z 39 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.