Automatyczna instalacja sterownika nvidia

Jesteś nowy na forum? Przeczytaj ...

Home Fora Forum wsparcia Sprzęt i sterowniki Automatyczna instalacja sterownika nvidia

Ten wątek zawiera 61 odpowiedzi, ma 7 uczestników, ostatnio zmodyfikowany przez  michaldybczak 1 rok, 5 miesięcy temu.

Oglądasz 15 posty - 46 do 60 (z 62 ogółem)
  • Autor
    Posty
  • #5088

    Nencio
    Forumowicz

    Uważnie jeszcze raz po kolei przeinstaluj wszystko i czy Ci ponownie sypnie błędami ale uważnie wklejaj komendy.

    #5089
    aquila
    aquila
    Moderator

    Podaj:

    inxi -Gxx
    mhwd -li
    systemctl status bumblebeed

    Czy działa:

    optirun glxgears -info

    #5090

    nikczemnik
    Forumowicz
    [hary@acer ~]$ inxi -Gxx
    Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
    Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:0416
               Card-2: NVIDIA GM108M [GeForce 840M] bus-ID: 01:00.0 chip-ID: 10de:1341
               Display Server: N/A driver: modesetting tty size: 88x28
    [hary@acer ~]$ 
    
    [hary@acer ~]$ mhwd -li
    > Installed PCI configs:
    --------------------------------------------------------------------------------
                      NAME               VERSION          FREEDRIVER           TYPE
    --------------------------------------------------------------------------------
             network-r8168            2016.04.20                true            PCI
    video-hybrid-intel-nvidia-bumblebee            2017.03.12               false            PCI
    
    Warning: No installed USB configs!
    [hary@acer ~]$ 
    
    [hary@acer ~]$ systemctl status bumblebeed
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: d
       Active: active (running) since Thu 2017-07-13 19:45:53 CEST; 56min ago
     Main PID: 25354 (bumblebeed)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/bumblebeed.service
               └─25354 /usr/bin/bumblebeed --use-syslog
    
    lip 13 19:45:53 acer systemd[1]: Started Bumblebee C Daemon.
    lip 13 19:45:53 acer bumblebeed[25354]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ 
    lines 1-10/10 (END)
    
    hary@acer ~]$ optirun glxgears -info
    [hary@acer ~]$ 
    [hary@acer ~]$ 
    

    Ech to Was na dzień dobry umęczyłem:)

    #5092

    Nencio
    Forumowicz

    Co do ostatniego to masz zainstalowaną mesa?
    I czy ponownie sypnęło błędami?
    Ja od razu przy instalacji wybrałem instalację nonfree sterownika.

    #5096

    nikczemnik
    Forumowicz

    Nie wiem jak mam wpisać wersję kernela.
    Czy tak?
    sudo mkinitcpio -p * linux49
    sudo mkinitcpio -p *linux49

    Przy pierwszej wersji wyskakuje komunikat: mkinitcpio: invalid option — ‚i’
    Przy drugiej wyskakuje to: `[hary@acer ~]$ sudo mkinitcpio -p *linux49
    /usr/bin/mkinitcpio: linia 271: /etc/mkinitcpio.d/*linux49.preset: Nie ma takiego pliku ani katalogu
    ==> ERROR: Failed to load preset: /etc/mkinitcpio.d/*linux49.preset'

    #5097

    Nencio
    Forumowicz

    Tak:
    sudo mkinitcpio -p linux49
    Bez żadnych gwiazdek. Dokładnie taki jak ci wyświetliła komenda:
    mhwd-kernel -li
    Ale najpierw musisz mieć zainstalowany kernel.
    Względnie zainstaluj nowszy:
    sudo mhwd-kernel -i linux411
    Lista dostępnych:
    mhwd-kernel -l

    #5098

    nikczemnik
    Forumowicz

    Przy próbie instalacji kernela:

    https://pastebin.com/pAh8sXnC

    #5099

    Nencio
    Forumowicz

    Coś masz skopane jak nie ma miejsca skoro niby masz miejsce.

    #5100

    nikczemnik
    Forumowicz

    Dobra spróbuję zrestartować i może wtedy ruszy a w razie czego przeinstaluję system albo wrócę na Ubuntu- tam przynajmniej nie musiałem komuś d… zawracać jak coś się działo:-).

    #5101

    Nencio
    Forumowicz

    Zrestartuj jak Ci nie wstanie środowisko graficzne to ctr+alt+f2 i z konsoli po zalogowaniu po instaluj.
    Też się przesiadłem z Kubuntu i raczej na plus określam tą przesiadkę pomimo, że musiałem wertować internet z problemami.

    #5102
    aquila
    aquila
    Moderator

    Po jakiej konkretnie komendzie masz ten błąd?
    Nie wrzucamy tak długich logów na forum tylko na jakiś pastebin, poprawiłem.

    #5103

    nikczemnik
    Forumowicz

    No i nie wstal:-) Kernel panic. Do trybu tekstowego tez nie dalo sie wejsc alt ctrl f2 ani f3 nie dzialalo. No nic wezme sie za reinstalke ale to chyba jutro.
    Tak czy siak chcialem Wam wszystkim podziekowac za natychmiastowa pomoc.
    Dzieki serdeczne i milego wieczoru

    #5104

    czapnaper
    Forumowicz

    Problem z brakiem miejsca wynikał z tego ze /tmp był w 100% zajęty.

    Miejsce chyba jest

    [hary@acer ~]$ df -h
    System plików  rozm. użyte dost. %uż. zamont. na
    dev             3,9G     0  3,9G   0% /dev
    run             3,9G  1,2M  3,9G   1% /run
    /dev/sda1        47G   14G   31G  31% /
    tmpfs           3,9G   29M  3,9G   1% /dev/shm
    tmpfs           3,9G     0  3,9G   0% /sys/fs/cgroup
    tmpfs           3,9G  3,9G  8,0K 100% /tmp
    /dev/sda3       847G  284G  521G  36% /home
    tmpfs           789M   24K  789M   1% /run/user/1000
    [hary@acer ~]$ 
    

    By sobie z tym poradzić można przydzielić więcej miejsca poleceniem sudo mount -o remount,size=10G,noatime /tmp.

    Manjaro Gnome/Xfce - CPU - i5-7300HQ - GPU - Intel/NVIDIA GP107M [GeForce GTX 1050 Mobile]

    #5109
    azja
    azja
    Moderator

    /temp korzysta z RAM’u. Tak naprawdę, to rodzaj RAM-dysku. Domyślnie, używa max 50% RAM’u (w zależności od potrzeb). Byłbym ostrożny w ustawianiu na stałe dużego temp’a. Chwilowo, po to, aby skompilować coś, czemu nie. Przedtem jednak może włożyć wtyczkę urządzenia elektrycznego do gniazdka, czyli … przeczyścić /temp. Był zapełniony, zapewne, wskutek wcześniejszych operacji (kompilacje, instalacje).

    Nie zadawaj pytania, jeżeli nie jesteś gotów usłyszeć odpowiedzi

    #5120

    Nencio
    Forumowicz

    Spotkałem się z tym pierwszy raz. Nie zwracam zazwyczaj uwagi na to.

Oglądasz 15 posty - 46 do 60 (z 62 ogółem)

Musisz być zalogowany aby odpowiedzieć w tym wątku.